Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Can't enable add-on

edited May 2008 in Vanilla 1.0 Help
I installed and am running the latest version of vanilla for some weeks. I get this message when trying tho enable a new add-on by checking the box. There was a problem authenticating your post information I can work around it by editing the conf/extensions.php file but there is more trouble: I also can´t change the forum settings. I am the administrator. The setteings don't stick. No error message this time. I have read about people having similar problems, and tried the suggestions made there, but with no result. I think all access rights to my files and folders are ok (777) and I don't believe there is a problem whith session coocies. Can someone help please.


  • Check the javascript files, make sure they are coming across to the browser OK. If they are, then try re-downloading them from
  • Thnks for trying. I downloaded the scripts, but no change.. Also I think vanilla pages load very slowly, not just my installation but this forum as well!? CU Johan
  • Everything is running smoothly here. My own Vanilla forum is also very speedy.

    Where is your forum installed? What kind of bandwidth are we talking?
  • Hello slartie. Ok i'm on a mobile connection now with only 380 Kb/s that might be it. My forum server is at, I have several domains there and the other ones are loading faster. But ok thanks for your comment. Johan
  • Has this error ever been solved? I am having the same problem. I cannot enable or disable extensions and I get the 'problem authenticating your post' error. I have been scanning Google and the forums like crazy trying to figure it out.
  • Try checking your cookie domain setting.
  • I was very disheartened to find this string ends with no real solution except changing servers as a possibile fix. Some extensions work, adding a WYSIWYG directory will not take manually or automatically with ANY account permission settings.
  • This string basically comes to the same conclusions. Very frustrating
  • I commented out this check in switchextensions.php and switch.php // if ($PostBackKey != '' && $PostBackKey == $Context->Session->GetVariable('SessionPostBackKey', 'string')) { $ExtensionForm = $Context->ObjectFactory->CreateControl($Context, 'ExtensionForm'); if ($ExtensionForm->SwitchExtension($ExtensionKey)) { echo $ExtensionKey; } else { $Context->WarningCollector->WritePlain(); } /* } else { echo $Context->GetDefinition('ErrPostBackKeyInvalid'); } */ It works but without protection from outside hacks
  • Wouldn't it be better to fix the session issues on your server?
  • What combination of permissions are required to fix the sessions? i cant seem to find the correct combinations of permission settings
  • Nothing to do with permissions generally. What do you have your cookie path and domain set to?
  • cookie path is set simply to is there a more applicable path?
  • Correction: cookie domain is cookie path was: /forumfolder/ i reset it to the entire URL:
  • I can tell you once the extension is checked to load a WYSIWYG or HTML buttons, i get a javascript error on the IE browser.
  • Please strike above. this extension seems to work versus the one i was attempting CommentAuthorliquidguy CommentTimeJun 14th 2007 *phew*, that took a bit longer than I thought. Ok, let's call this unofficial version 0.2, shall we? BBInsertBar v0.2 New Thangs: Completely re-written Javascript functions Works in both BBEdit/HTML mode Confirmed working in: Firefox 2.x Camino 1.5 Safari 2.x Internet Explorer 6 Internet Explorer 7 Now prompt-free! Replaced the annoying prompt popups with a much easier-on-the-eyes overlay Image button now shows you a live preview of your image before you post. Things yet to do: I'd like to clean up the HTML further, but I didn't have enough time... The color bar formats weirdly in both IE's. It's still usable, but doesn't look as nice as FF/Safari. I didn't test this with smilies on. Can someone double-check? YouTube option still a no go. I'll take a closer look if there's enough need for it.
  • I dont understand your latest post.
  • BBC insert bar does show up but still doesnt work. The problem as best i can tell is a java script error in IE. Each attempt at loading a discussion with any HTML editor checked in extensions shows a fault in the browser to this effect Error: "dojo" is undefined
  • Try disabling the dojo extension.
This discussion has been closed.