Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

language(charset) problem in vanilla..

edited March 2008 in Vanilla 1.0 Help
hi there, i have just installed the latest version of vanilla, and uploaded turkish translation package in to the "languages" folder.. i want to serve my forum in "turkish" to my visitors.. but whenever i choose the turkish option from the administration panel i see weird characters such as "?" (question mark) in the translations.. i have not got any problem with the entries.. i can see the special chars such as "ş","ğ" or "ü".. i guess there is a problem with the charset of the forum or something like that.. i set my mysql database (and the tables inside it) up in "utf8_general_ci" think the problem is because of that? i haven't changed or edited any file neither in vanilla nor in the language add on.. please help me.. i have been trying to fix this issue for about 3 hours.. thanks for your interest..


  • i ve checked there at least for 3 times before you gave the link.. but i still cant fix it.. my db is utf8, connection charset is also utf8 and the vanilla charset is utf8 too.. i am gonna go crazy..
  • Hmmm...well that documentation seems to have been sufficient to help out everyone else with similar problems. Try taking the <?php off the start of the language file and browse to it...see how it looks.
  • edited March 2008
    it seems to be OK.. there is no character problem while browsing on my own computer.. language file all coded in UTF-8.. BUT when upload it to my server and try to browse from that location i see the same weird chars.. i couldn't get what the problem is... :( the problem is because of the definitions.php file.. it changed somehow after i had uploaded it..
  • I wonder if it's some strange set up on your server...could you try asking your host about it?
  • Copy your file in a new folder on a server. When I replaced a current language file in other encoding I had a same problem
  • sorry but, i couldn't get what you trying to say.. could you please tell me the way step by step to get rid of this problem..
  • as i understood,you rewrite old file on a server. Trying create new folder and copy in it.
    It is simple, but it helped me, when I had a similar problem.
  • i deleted the languages folder and all the language files including the definitions.. i created a new folder and copied the "Turkish" language folder into it.. but i still am facing the same problem.. :( is this the way that you wanted me to do?
  • i just discovered something.. if i change the format of the definitions file (for example making it, .html instead of .php) which is in the languages folder and try to view it, i can see all the chars correctly.. there is no problem.. but when i change it back to the .php format and select it from the admin panel then the same problem occurs again.. isn't there anyone can help me?? don't you have an idea?
  • edited March 2008
    The first thing I would do would be to put back the languages folder and all its contents to what it was originally. Then I would make sure I read the readme that is in the language you downloaded.

    I just tried and it worked with the Hungarian language. I just copied the entire Hungarian folder and put it into the languages folder.
  • Jumping in late…
    My bet is: If you can read the file content ok when served as html and not when served as php, there is probably a wrong encoding of your file content. Default setting of http server is not UTF8, most often. So I'd double check that there were not some unwanted transcoding in the process.
    Do this test: look at you file, served as php, and toggle the page display in your browser to use utf-8, is it ok?
    Another point: you said that you installed the last version of Vanilla. Was it a fresh install or an upgrade?
  • edited March 2008
    @jimw i put back the languages folder to the same it was.. but no change :/ btw, there is no readme file inside of the Turkish languages pack.. @Max_B i checked the charset of the server again and i am sure that it is utf-8.. and also i tried to view the php file without the "<?php" code at the beginning of the file and i faced the problem again.. i changed the charset to UTF-8 via my browser.. but it didn't changed the situation.. :/ without deleting "<?php" i can't view the file manuel on the browser.. i face with a blank screen.. i didn't upgrade it.. this is the first time i am trying to install vanilla.. i mean it is a fresh install.. if you wanna i can give you my hosting access and you can see the problem with your own eyes :/
  • OK, so from your test we can assume that the translation file is not utf-8. It is either latin1 or some other encoding relevant to turkish.
    Do the same test again (display the language file without the opening php tag) and try switching the browser charset until it displays ok. Then you know the file encoding.
This discussion has been closed.