Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

404 error after 'successful' installation

edited June 2009 in Vanilla 1.0 Help
Hi, I am trying to install Vanilla 1.1.4 in which has PHP 5 and MySQL 5 and also has Wordpress 2.5 installed with no problems (on a different DB), but after a 'successful installation' I get the following problems: * When I click the initial 'get started link' to I get a 404 error, even though I can clearly see it in FileZilla. * When I visit I also get a 404 error (as does and * However non-PHP files such as /forum/readme.html and /forum/js/ac.js work fine! When I say a 404 error I mean that in FF2 I see my custom Wordpress 404 page (WP is installed in and in IE7 I see "The webpage cannot be found". Is this some conflict with Wordpress? Or have I done something wrong? (I have double checked all permissions and database details) Thanks in advance, Rob


  • Oh, by the way - I am not trying to integrate Vanilla with Wordpress
  • are you using friendly urls for wordpress? I've a feeling that set up can be pretty aggressive when putting other stuff in subfolders...
  • Yeah I am. Do you know is there any way to get around this? Any sort of htaccess code or something? Thanks
  • Can you just try disabling friendly urls on WP for a minute and see if it fixes it?
  • Thanks. I'll try it and see.
  • Ok, I've tried it and now I get a 500 Internal Server Error! Switched back to custom permalinks and I'm back to the same problem.
  • Do you have access to your server logs to try and see what's going on?
  • How can I check my server logs? I've got cPanel, if that helps. Thanks for your help
  • Ok, this is the error that is repeated several times in my error logs (now that I've found them): [Thu Apr 10 14:25:05 2008] [error] [client] Premature end of script headers: /home/rupham/public_html/forum/index.php SoftException in Application.cpp:246: Directory "/home/rupham/public_html/forum" is writeable by group Do you know what's going on?
  • It seems to be objecting to the directory being 'writable by group', but isn't that what Vanilla tells you to set the permissions? Just tried changing group permissions - no change...
  • vanilla just tells you to set user/group/world (0777) write permissions for the "/conf" folder of the installation. for security reasons it is necessary to set the permissions to 0755 for all other directories and 644 for all other files. after you changed all the permissions, checked the site and it doesn't work: check the logs again... it may be possible that your web-hoster does not allow permissions greater than that (d:0755, f:0644).
  • Thank you both so much! It is now working! In case anyone else ever has the same problem - this is exactly what I did: * Set all the permissions for files inside the /forum/ (or whatever) directory to 644 * Set all the permissions for directories inside the /forum/ directory to 755 * Set the /conf/ directory to 777 * Set the /forum/ directory to 755 One more question please - does the /conf/ folder need to stay 777 after installation or can I change it to 755? Thanks a lot!
  • it needs to stay 777, because a lot of the configuration settings are stored there.
  • Ok thanks
  • I'm having the same problem, but I've tried setting the permissions as above and that didn't fix the issue. I'm guessing I need to add something to my .htaccess file - but what? (I'm not using friendly URLs in Vanilla, but I am in WordPress - also NOT trying to integrate w/ WordPress, just run Vanilla in a subfolder) My host is HostGator, and I guess people have a lot of 403 errors with Vanilla with them. I checked with them and they said it's not the mod_security issue that others have complained about (or I'd be getting 403 errors and not 404 errors).
  • I had the same problem, but without the wordpress stuff.

    Spent a couple of hours googling, until I discovered that after installed Vanilla 2, you have to ENABLE the vanilla and conversations under APPLICATIONS menu.

    Sad that on the readme.html there's no follow up about it.
Sign In or Register to comment.