Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

can't sign in

edited November 2008 in Vanilla 1.0 Help
I've installed vanilla for the first time on my server. Everything goes well until I try to sign in on the /people.php page. I can't login but there aren't any errors. I've read all the posts and tried '' for cookie_domain as well as ' ' and all other suggestions I could find -still can't sign in. I'm guessing I'm having a problem because I've got a multiple website hosting plan and installed vanilla in a folder serving a domain other than my primary domain. ( Any ideas on how to get things working from here. (I just want to test from here before moving to a dedicated host) thanks in advance


  • Options
    your cookie settings should be "" (not
  • Options
    you know, I tried that and every other combination I could think of for COOKIE_DOMAIN, COOKIE_PATH, WEB_ROOT, BASE_URL etc it must be some combination of 2 or more settings that need to match for it to work anyone else get it working in this type of setup?
  • Options
    cookie_domain: cookie_path: /domain/
  • Options
    I've got it on the same type of setup. Cookie domain should be the domain you access the forum through, and patch should be either '/' or the folder the forum is accessed through.

    i.e. should have for the cookie domain, and /forum/ for the cookie path.
  • Options
    I have a sign in problem that I'd appreciate some guidance on please.

    Recently my hosting service changed servers and all us users had to migrate our websites and forums across. I managed this OK (after a few hassles) and took the opportunity to do a complete re-install of the latest Vanilla software. (I felt I had some bugs in the existing files because I may have fiddled with things.) I copied the DB across and everything came up roses. Until today.

    The forum isn't really in use at the moment, so I went to go in today as Admin to do some tidying up, but I couldn't get in - I got an error message saying the password & username didn't match, and even when I requested a new password and used that, I still couldn't get in. I tried a second account I have for testing, and I was signed in OK, but when I logged out and tried to sign in again as that user, I got the same error message, which really made me think.

    I wondered whether it could be a cookies problem, in which case I might have to check with my service provider whether I have the right Cookie Domain and Cookie Path. Does anyone who knows more than I do about this (which is pretty much everyone!) know if that seems like the problem, or maybe something else? Thanks.
  • Options
    edited November 2008
    Reinstall people (library/People), then check that the database has been upgraded (the type of the Password column in the LUM_User table should be VARCHAR(34)). If it is still VAR(32) see this post:
  • Options

    Thanks a lot for your prompt attention. I can see from the topic you referenced that you've had a lot of requests. I really do appreciate your efforts.

    The good thing is, I seem to have it working. Reinstall files didn't change anything, but manually changing the variable from 32 to 34 did the trick (thanks for the code, I couldn't have done that myself), although I had to email myself to set a new password before it worked. Thanks again.
  • Options
    edited November 2008
    Many people who have moved and updated the forum at the same time had this problem. To avoid these problems you should update before backing-up your database or after installing the database on the new server.

    Every user that logged-in on your forum since you moved and upgraded your forum will have to request a new password.
This discussion has been closed.