Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Header link path issue

edited April 2008 in Vanilla 1.0 Help
Hi everyone,
I'm new to Vanilla and would consider myself decently able to find my way around the files structure and generally poke around. I installed it on my server and everything is great. Except in my header, the links point to the wrong path.
I used an add-on domain to a hosting package I already pay for, and the links point to my original domain. How would I get these to point to the add-on domain? I've got a feeling a forward slash is missing somewhere. I hope I am being clear. Check it out here. Thank you in advance!!


  • Options
    You have the correct URL under "Web-path to Vanilla" in the Application Settings page?
  • Options
    in the mean time (and to change the setting), you will have to manually change the url after each link. Also, it may be easier to scour your /conf/settings.php to find any references to the old domain. (scour's not the best word, there should be only one reference to your old domain, the "Web path to Vanilla" mentioned above, except if you have any other addons, such as attachments0
  • Options
    Thanks for the quick replies. When I checked my Web-path to Vanilla, it was pointed to my new (i.e. add-on) domain. From what I under stood from you, fysicsluvr, I changed that URL to the full length, old domain path. Now things are a bit screwy and I can't access settings.php. Did I make a mistake?
    Thanks again!
  • Options
    you need to change the path to vanilla to "". It may be hard to do that now that it's set wrong, so you should download (via ftp) your /conf/settings.php file, edit the setting manually, and re-upload it.
  • Options
    The original path to vanilla was I was able to revert it to this thanks to your suggestion regarding downloading the settings.php file. However, the links at the top are still referring to the full (and wrong) path. Any ideas?
    Thanks for your help so far,
  • Options
    Also, I am trying to change the links manually, but (if you haven't picked up on it yet) I'm not that well versed in the backend (i.e. PHP) code. Where exactly can I find that HTML on the index, categories, search, settings, etc pages?
  • Options
    no, it's a lot more dynamic than that; it's in the file, which contains a lot of the settings for vanilla. Just find anything in there (ftp) that references and change it to the new path. (just keep the syntax the same; look at what it is now, and the other lines, and you should be ok.)
  • Options
    Hmm. Odd. No references to that old domain in that settings.php file. I even tried hard coding all of the paths to No luck.
    Thanks for your help so far.
  • Options

    do you have pagemanager installed?
  • Options
    Yes sir.
  • Options
    you need to resync your tabs! this should resync your tabs if you're logged in!

    I love being able to post a magical fixing link!

    Let me know if it doesn't work!
  • Options
    Holy crap! That was magic. Full success. You rock. Thank you infinitely!!
  • Options
This discussion has been closed.