HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Help! Chinese characters become "?"

edited May 2008 in Vanilla 1.0 Help
I installed the Chinese pack, and the Chinese interface works perfect but in those reply & topic the Chinese characters become "?" It's 1.1.4 ,and I add $Configuration['DATABASE_CHARACTER_ENCODING'] = 'utf-8'; to conf/settings.php

Comments

  • I think the Chinese character encoding is something else, try doing a Google search, I'm afraid the only word I know in Chinese is "Kook-bo" that's the tea we order at Yum Cha!
  • OK my problem has solved,mysql encoding Thanks a lot
  • Hi, wslight, I got the same problem. Could you tell us how to solve it? Thankz.
  • billtwy

    1)check your settings.php if it has the $Configuration['DATABASE_CHARACTER_ENCODING'] = 'utf-8'; line, if not added it
    2)check your phpmyadmin for what connection it uses on default - should be utf8_general_ci
    3)check your database tables, they should be collated as utf8 , if not you need to follow these steps to re encode your database -Vanilla UTF8 wiki

    I had similar problem and this is how I fixed mine - Japanese comes up as ?????? # 3

    Cheers
This discussion has been closed.