Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Japanese comes up as ??????

raykrayk New
edited May 2008 in Vanilla 1.0 Help

Whenever you try to type Japanese or any thing else apart from English on my forum it comes up at ???, If you hit preview, the characters show up with no issues, but after you hit submit they just come up as ???.

I've tried searching the forum to find an answer, but what I found doesn't seem to fix my issue.

My database is set to utf8, the database.php file has database encoding set to utf8 too. I looked at the settings.php file, found it was missing these two lines:

$Configuration['DATABASE_CHARACTER_ENCODING'] = 'utf8';
$Configuration['CHARSET'] = 'utf-8';

But after adding the problem didn't go away.

Any help is appreciated. Thank you!


  • There was someone with the same problem (but with chinese), and I think they said it had to do with their MySQL db settings.
  • ok fixed!

    Seems everything was set to utf8 , but the database tables were latin1(missed that the first time checking it all). I did export -> convert to utf8 (notepad++) ,removed DEFAULT CHARSET=latin1 line from the sql file, dropped the tables in phpmyadmin and reimport the changed sql file.

    All working ;)!
This discussion has been closed.