Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

language.php and .htaccess?

ericcarlericcarl New
edited May 2008 in Vanilla 1.0 Help
So I'm attempting to edit conf/language.php to change some of the verbiage on my Vanilla forum. I'm altering my files in Dreamweaver and uploading through the file browser, but when I attempt to upload language.php, I get an error about permissions not allowing me to upload the file. There is a .htaccess file in the conf folder with this content: <Limit GET POST PUT> Order Allow,Deny Deny from All </Limit> Is this somehow limiting Dreamweaver's ability to upload the file? Don't I need to be able to do this to make these verbiage changes? Thanks for any help!


  • Options
    you need enough permissions to write in the conf folder, imho, it's not an issue with .htaccess
  • Options
    Hmmm, I would remove that .htaccess file and see if that's what's causing it. You could always put it back.

    Actually, I would rename it, keeping the starting dot where it is.

    By the way, if you are running OS X or Linux, copying this file to your hard disk will cause it to disappear, that's what the dot does.
  • Options
    well, on linux you can find it just Ctrl+H ;)
  • Options
    You can find it on Mac OS X too (log in as root), I just wanted to keep it simple and not complicate things for the poor guy.
  • Options
    I'm too new to the mac world to know all these lil' tricks :(
    step by step..
  • Options
    Well, I tried renaming the .htaccess file, didn't make a difference. So I doubled-checked the permissions on language.php, and they are set to 644. When I try to change those, I get an error saying that setting access properties failed.
  • Options
    does it output anything more about that error?
  • Options
    I'm in Dreamweaver, so all I get is: ============================== Setting access properties failed for: / For additional information, check the FTP log. ============================== But checking the FTP log doesn't seem to show any details at all about that action.
  • Options
    If you can't change the permissions on the language.php file then you are not the "owner" !

    Contact your ISP and get them to change the owner of all the Vanilla files to whatever your user is.

    Posted: Friday, 23 May 2008 at 8:15AM

  • Options
    Sounds fun. I'll have to investigate.
This discussion has been closed.