Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

migration problems

edited July 2008 in Vanilla 1.0 Help
Hi folks,

We migrated a Vanilla forum from one server to another. I ran into a weird problem (both sites were/are hosted) where the transplanted site wouldn't run. Nothing. Nada. Nothing in logs just sat there.

So I did a fresh install and made sure Vanilla was happy with the new ISP and it was. Then I loaded in the DB and copied over the extensions/themes and besides a bit of DNS misery and some extension hackery (turning them off in extensions.php then back on)everything was ok.

During testing I have now discovered the Discussion Prefs for Sticky/Unsticky and so on do not work. Trying to make a discussion unsticky (as a user with confirmed ability to do so) resulted in being logged out. I then used the 'remember me' function but I can't seem to get any of those bits to work.

It was logging to the error file originally but I echoed a newline in for the sake of debug and now it isn't writing to the file anymore.




  • XKXK New
    edited May 2008
    can't modify extensions through the GUI now as well. :(

    Sorry it says "There was a problem authenticating your post information"

    I tried some things from this issue but the session addition to nit_vanilla.php didn't seem to change anything.
  • XKXK New
    Well my other Vanilla site on the same server can use the sticky/unsticky/turn extensions on and off so it's just something busted inside of this franken one. any suggestions what could be causing it? thank you!
  • My guess would be the whole ajax folder... the ajax pieces handle the adding/removing of extensions and changing discussion properties. Might want to re-upload the js folder too, since js is a part of ajax.
  • XKXK New
    edited May 2008
    Thank you for the suggestion, WallPhone! I'm comparing the busted install's ajax and js to the working one's and they have the same perms and file sizes plus no change in modification status in the busted one's timestamp. I'm not sure what would be throwing the 'there was a problem authenticating your post' message with the extensions but the error log doesn't spit anything out. Edited to add: I also have my conf perms wide open in the busted install to see if that would help but no joy. I really appreciate your help and suggestions!
  • I did the transfer again and it fixed it.
This discussion has been closed.