Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Settings.php is returning a blank page

I'm new to Vanilla but really enjoying it so far. I'm pretty sure I broke my forum last night and I need some help getting it back in order.

Here's what I did:
1) I realized that Friendly URLS was breaking the Private Message Extension (has no one addressed this yet?) so I tried to revert to non-friendly URLS
2) I deleted the .htaccess file and removed the " $Configuration['URL_BUILDING_METHOD'] = 'mod_rewrite';" from settings.php
3) as soon as I did this every page of my forum started redirecting to a 404 on my main site (the forum lives in
I assume this is because despite my deleting the .htaccess, Vanilla was "stuck" trying to do Friendly URLS
4) I put the .htaccess back, and appended the settings.php again
5) everything worked as before but the settings.php page now returns a blank page with no error

What I've tried so far
1) made sure I uploaded settings.php in ASCII format
2) checked permissions on settings.php

If anyone can help it would be greatly appreciated. Right now I can't even approve new members.



  • The default install of Vanilla doesn't have a .htaccess file so it should be safe to remove it. Just for clarification, did you remove URL_BUILDING_METHOD from conf/settings.php or appg/settings.php? Nothing should be changed in appg/.
  • I removed "$Configuration['URL_BUILDING_METHOD'] = 'mod_rewrite';" the first time, but I put it back just to try and get things back the way they were. Friendly URLS is working right now, but settings.php is blank.

    The only other time I had this problem was when i was installing Vanilla and uploaded in binary mode. When I reuploaded in ASCII mode all the blank pages were visible. That's not the case this time.

    Also (if it makes a difference), settings.php IS working. All my settings are correct and functioning. I just can't see the page on my forum.
  • @Sirlancelot

    You made me realize my mistake!

    I overwrote root/settings.php with conf/settings.php

    Replaced it with the original file and everything is working again. Thanks!

    Now I just need to figure out how to get Private Messages working with Friendly URLS.
  • oh wow, never though about that one :) Glad you got it all worked out.

    As for Friendly Urls and Private Messages, I just found this: Private Messages 1.1 # 73

    I don't use the extension so I can't verify this works, but you might want to give it a try. It seems that the files linked in that comment don't work anymore... At least you have someone you can contact now though.
  • @Sirlancelot

    Way way way way way down in that thread there is a working link to a fixed version of Private Messages. Someone should update the actual Extension.

This discussion has been closed.