Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Cannot install Vanilla on Windows2003+IIS ?

edited September 2005 in Vanilla 1.0 Help
Hi I'm having this problem when I try to install vanilla on my win2003 server. I'v set up this in aggp/settings.php define("agAPPLICATION_PATH","C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla"); But when I run the installer, it gives me this info: Vanilla is going to need read AND write access to the following files: * C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla/appg/settings.php * C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla/appg/extensions.php * C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla/appg/language.php * C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla/database.sql I'm confused with those forward and backward slashes.... What should I do to set up this correctly? Thanks

Comments

  • Options
    Change yor setting to be: define("agAPPLICATION_PATH","C:/Inetpub/vhosts/mydomain.com/httpdocs/vanilla"); It could also be that the user running IIS (or one of those funky in built users that IIS mysteriously uses) needs read/write access to the files.
  • Options
    I'm thinking its more the permissions line of things but changing the slashes is sensible anyway. That said i cant even get php and iis working :(
  • Options
    edited September 2005
    No it doesn't work. I chage the "\" to "/" but the installer still give me this: * C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla/appg/settings.php * C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla/appg/extensions.php * C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla/appg/language.php * C:\Inetpub\vhosts\mydomain.com\httpdocs\vanilla/database.sql I don't think the installer ever uses "agAPPLICATION_PATH" because even I set it like this define("agAPPLICATION_PATH", ""); same thing happens
  • Options
    Set those files to be readable, writable by Everyone and try again, if that works then work out what the IIS permissions need to be. I think the installer actually uses getcwd and not what is in the settings file but I don't think that is causing your problem, if it is though you could find where getcwd() is called in the installer and replace it with the string of your path with forward slashes.
  • Options
    Thanks, jaseone. I've installed vanilla. I changed getcwd() in installer.php to "c:/inetpub/vhosts/mydomain.com/httpdocs/vanilla/" Then set up the permissions...minisweeper is right, set up permissions on windows is more complicated than in Linux....but anyways, it works now. sweet!
  • Options
    MarkMark Vanilla Staff
    When IIS serves a page, it uses the IUSER_MACHINENAME as the user who does it. So, you need to grant IUSER_MACHINENAME read and write permissions to those files. Of course you will need to substitute "MACHINENAME" for the name of your machine. Also, when it comes to back/forward slashes, windows doesn't care what you use, so I just always build my paths with forward slashes so that it will work on both linux and windows without any problems.
  • Options
    That's theoretically true. However, installing Vanilla on my xampp did result in an installation that didn't work. It produces errors looking like somewhere the \ were interpreted as escape character, resulting in messed up paths. Replacing the line in installer.php $WorkingDirectory = getcwd()."/"; to $WorkingDirectory = str_replace ("\\","/",getcwd())."/"; made it work without further problems. So maybe this should be put in the release? It shouldn't disturb installations on linux.
This discussion has been closed.