HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Having to log in twice

edited August 2008 in Vanilla 1.0 Help
If I go to my Vanilla forum's URL, I can log in normally. If I log out and then select "Click here to sign in again," I'm redirected to [MyURL]/people.php, instead of just [MyURL]. If I log in at [MyURL]/people.php, I'm presented with another login page, though if I click the Proceed button without entering my credentials I find that I really had been logged in the first time.

This is bound to confuse just about everyone. Is there a fix that can be put into 1.1.5, or is there a configuration change I can make on my end? I'm using a home-made authenticator on my forum, but I don't think that has anything to do with it.

Comments

  • If you click on the link to sign-in again you are redirected to a page to sign it - [MyURL]/people.php. Why should it redirect to forum home page? The bug that you mention after is specific to your installation. It seems the login page doesn't redirect you to the forum after it log you in.
  • edited August 2008
    If you are an admin and you successfully log-ed in, it might render themes/people_signin_form_validpostback.php (if application need to be reviews.

    In all other cases, it should redirect you to the URL set in the ReturnUrl parameter - eg, http://example.com/people.php?ReturnUrl=http://example.com/ - or to the default one set in $Configuration['FORWARD_VALIDATED_USER_URL']
  • Thanks--fixing $Configuration['FORWARD_VALIDATED_USER_URL'] did the trick. I had originally installed Vanilla with my forum's real URL, but for testing purposes I then changed the URL to a temporary name using the Settings page on Vanilla. While this changed $Configuration['BASE_URL'] in settings.php, $Configuration['FORWARD_VALIDATED_USER_URL'] was still what I'd set at installation. Changing this to the temporary URL cured the problem.
This discussion has been closed.