HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Can't update & Add-on errors. Please help.

edited August 2008 in Vanilla 1.0 Help
I have Vanilla 1.1.4. When I click "check for updates I get this error popup: Error: First Vanilla Is Up To Date. Then it own't check any of hte extensions for an update...

I tried to install a few new add-ons. It says:
Some problems were encountered
DefaultIcon requires the Redirect() function. Please make sure that you have the latest version of Vanilla. If you do please check for the function in the 'library/Framework/Framework.Functions' file.
DefaultIcon needs to have write permission enabled on the icons folder.

I set the write permissions to 777. I'm looking at the 'library/Framework/Framework.Functions' file. I do not see what I need to change. Thanks for helping!!

Comments

  • i just read the whole file and i"m really not seeing what has to change...
  • You shouldn't have to change anything... but the kind of problems that you are seeing usually mean that Vanilla wasn't completey uploaded when you sent it to the server, so try re-uploading all the files again, (paticularly everything in the library folder and the js folder) then see if you can run the update check and enable those extensions.
  • okay thank you!!! I'll go try that now. Thanks so much!
This discussion has been closed.