Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Missing or corrupted errors

SubJunkSubJunk ✭✭
edited September 2008 in Vanilla 1.0 Help
When I try to do a fresh install of Vanilla I get a whole bunch of errors that files "might be corrupted". I've re-downloaded the zip file and overwrote all files but it still gives the same error. If I choose to ignore the errors it seems to work fine, but I'm not sure why it says they might be corrupted when they aren't. The error is:

Vanilla Installation Wizard (Step 1 of 3)

This wizard will first check the integrity and permissions of Vanilla files on the server.

We came across some problems while checking your permissions...
Some files seems to be missing or corrupted:
themes/settings_role_edit.php might be corrupted.
library/Framework/Framework.Functions.php might be corrupted.
themes/discussion.php might be corrupted.
themes/head.php might be corrupted.
ajax/updatecheck.php might be corrupted.
library/Framework/Framework.Class.DirectoryScanner.php might be corrupted.
setup/upgrader.php might be corrupted.
ajax/sortroles.php might be corrupted.
themes/settings_applicants_form.php might be corrupted.
themes/settings_role_list.php might be corrupted.
library/Framework/Framework.Class.IntegrityChecker.php might be corrupted.
setup/style.css might be corrupted.
themes/vanilla/styles/default/src/vanilla.css might be corrupted.
setup/installer.php might be corrupted.
library/Framework/Framework.Class.Uploader.php might be corrupted.
setup/index.php might be corrupted.
library/People/People.Control.ApplicantsForm.php might be corrupted.
library/People/People.Class.User.php might be corrupted.
library/Framework/Framework.Class.SqlBuilder.php might be corrupted.
ajax/sortcategories.php might be corrupted.
themes/notices.php might be corrupted.
library/People/People.Control.SignInForm.php might be corrupted.
readme.html might be corrupted.
appg/init_vanilla.php might be corrupted.
appg/init_people.php might be corrupted.
appg/version.php might be corrupted.
conf/readme.txt might be corrupted.
themes/settings_category_list.php might be corrupted.
themes/settings_category_edit.php might be corrupted.

Any idea what would cause this?


  • Options
    Are you sure all the files uploaded properly? This check step was added to the installer because many FTP clients seemed to choke or randomly corrupt when uploading a large number of files.

    If your host supports it (I.E. shell access), it might be a good idea to try unzipping at the server.
  • Options
    Yes I'm sure the files are all OK.
    I've re-uploaded them a few times, re-downloaded the zip file, unzipped it using winrar instead of winzip, and still it gives those exact files as an error no matter what I do. And anyway the forum works perfectly with the "corrupted" files. Very strange. The exact same files I FTP'd are running on this computer too and no errors running it locally.
  • Options
    You can try uploading appg/md5.php again. If you still get the same error, delete appg/md5.php.
    We will look at what went wrong.
  • Options
    This is fixed with 1.1.5a, thanks
This discussion has been closed.