Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

No images showing when forum is placed in a folder

RaizeRaize vancouver ✭✭
edited September 2008 in Vanilla 1.0 Help
My first forum installation went well, and it was a one level forum structure. (/mysite/index.php)

For a different installation on a different domain, the images don't show at all (/mysite/forum/index.php)

As you can see, I placed the forum in a folder within a folder, so when I set my domain to point to that folder, the images don't show for some reason. Is there something I need to change here? it seems like a rookie mistake


  • Options
    SubJunkSubJunk ✭✭
    edited September 2008
    It is most likely you have referenced your images like:
    <img src="/images/image.jpg" />
    If this is the case you need to either switch to using relative links (recommended usually) or change it to this:
    <img src="/forum/images/image.jpg" />
    Let me know if that fixes it.
    If that isn't the problem then providing a link to the forum will help because then I can see the code the browser sees and hypothesize better.
  • Options
    edited September 2008
    You probably need to update all these settings in conf/settings.php:
    $Configuration['APPLICATION_PATH'] = '/Path/To/vanilla/'; $Configuration['DATABASE_PATH'] = '/Path/To/vanilla/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/Path/To/vanilla/library/'; $Configuration['EXTENSIONS_PATH'] = '/Path/To/vanilla/extensions/'; $Configuration['LANGUAGES_PATH'] = '/Path/To/vanilla/languages/'; $Configuration['THEME_PATH'] = '/Path/To/vanilla/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/vanilla/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/vanilla/'; $Configuration['BASE_URL'] = ''; $Configuration['FORWARD_VALIDATED_USER_URL'] = '';
  • Options
    You also probably need to go in settings > themes & style and reset the style for all users.
This discussion has been closed.