HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Doesn't register login

edited September 2008 in Vanilla 1.0 Help
I've got a copy of vanilla that I installed for testing purposes, and it won't allow me to log in... more specifically, when I log in, it recognizes that I have, but doesn't keep me logged in. When I click on my user name, it shows my recent activity a few seconds before, but I'm not signed in. I was having the issue that the home page wouldn't show me as being signed in initially, but when I went to categories, it would recognize me, but now, after updating to 1.1.5, nothing, I cannot access my own forum. Anyone know what's going on? Should I just delete and find another forum software?

Comments

  • It must be a problem with your session or cookie settings. What are your cookie settings (in conf/settings.php)?
  • The settings are for the root site, I guess that might make sense, but the initial problem of not recognizing the signed in status was happening before I made that change. I'll try changing it back... I'll report back ASAP
  • edited September 2008
    Browsers won't accept a cookie set explicitly for localhost. If it is the problem, you should set $Configuration['COOKIE_DOMAIN'] to an empty string and let the browser set the domain by itself.
  • edited September 2008
    Okay, I'm sorry to ask stupid questions, but what should that line look like with an empty string?
  • Can you login when you tick the remember me option?
  • No, it doesn't make a difference.
  • So it is not a php session. I would try to reinstall the file and check again the cookie settings:
    # conf/settings.pgp ... $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/vanilla/'; ...

    What are you using? I just try a fresh install with xampp on vista on localhost and it's working fine.
  • with:
    $Configuration['COOKIE_DOMAIN'] = 'localhost'; $Configuration['COOKIE_PATH'] = '/vanilla/'; I have the same problem than you on ff3 but not on Google Chrome.
  • I'll try a fresh install I guess, I had installed 1.1.4 and had the first problem (some pages recognized the login, some didn't) then I updated hoping it would solve the problem... Can I do a fresh install and keep the database the same, or should I delete that as well?
  • Ah... I'm on FF3, that might make sense....
  • edited September 2008
    Nah, most browsers do the same for security raison. Chrome is the exception.

    You can keep the database, you just need to copy the file over your installation, in case one is corrupted and set the cookie settings to: $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '';
  • Now it's showing this error message: Parse error: syntax error, unexpected T_VARIABLE in ................../htdocs/forum/conf/settings.php on line 19
  • there is a syntax error in conf/settings.php: copy and paste it, if you can't find the error
  • Alright, with the fresh load, and adding semicolons to the end of lines 18 and 19 (my bad...) I got it basically working, it still sometimes doesn't realize I'm logged in on every page though...
  • So you add a problem of cookie, but might also have a problem of session? Is it installed on your computer or a server? If it is on a server check the documentation of your provider about session settings. You sometime need to change some settings. e.g., what I have to do on mediatemple.net: http://lussumo.com/community/?CommentID=65028 (errpostbackkeyinvalid? # 6)
  • Thanks a bunch for all your help, it seems to be working now!
This discussion has been closed.