Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Filebrowser oddity - failure to thumbnail certain files.

edited November 2006 in Vanilla 1.0 Help
Forgive me if I missed an answer to this in the forum and docs. I've got Filebrowser up and running and quite simply, it's failing to thumbnail only the files in aparticular sub-directory. The thumbnailer stalls with a blank white screen at what would normally be the "batch operation completed" report. Permissions on that subdir do not appear to be any different. I'm stumped. Any suggestions?


  • MarkMark Vanilla Staff
    1. Do you have other subdirectories that do get thumbnailed properly? 2. What is the directory name that is failing to be thumbnailed? 3. Do you have any hidden directories?
  • 1. Other subdirs on the same level as the problem dir work. 2. The failing directory is named "wip" without the quotes. 3. No hidden directories I am aware of. If you wanna play with it, the URL for my thumbnailer.php is - the wip subdir should show up with "commissions" and "original" both of which seem to work.
  • MarkMark Vanilla Staff
    Okay, this is going to be tougher to figure out than I had previously thought.
    We're going to need to go through it function by function to see where it's messing up.

    Add the following code to your thumbnailer.php file:

    // On line 1262 of thumbnailer.php: echo("<div>Found GenerateThumbnails</div>"); // On line 864 of thumbnailer.php: echo("<div>Found GetFiles</div>"); // On line 1297 of thumbnailer.php: echo("<div>Found GenerateThumbnail</div>"); // On line 186 of thumbnailer.php: echo("<div>Found AddError</div>");
  • I only recently began dealing with this stuff, so bear with me. I've added that block of code with { seperators, and so far, the thumbnailer.php doesn't come up at all with it in there. Where should I have the code? (Will reply tomorrow - it's late here, EST.)
  • MarkMark Vanilla Staff
    edited September 2005
    Basically, I want to get those echo's in right after the declaration of their functions.

    So, your code should look something like this:
    function GenerateThumbnails($yada, $yada, $yada) {
    	echo("<div>Found GenerateThumbnails</div>");
    and this
    function GetFiles($yada, $yada, $yada) {
    	echo("<div>Found GetFiles</div>");
    See what I mean?
  • Okay, I have added the echo lines to thumbnailer.php and now when I try to thumbnail the errant directory, I get a screen that returns: Found GetFiles Found GenerateThumbnails Found GetFiles Found GenerateThumbnail
  • it strikes me that the file named hidiko.jpg thumbnails in neither the commissions or wip directories but all the rest are fine. How odd. Stupid theory, but just try renaming it slightly to settle my mind.
  • Hang on to your hat, it's about to get weirder. Somebody suggested that perhaps the jpg which is not working had been saved by a program that produced an off file - said some thumbnailers do not like certain flavors of jpg. So, I tried opening the jpg and recompressing it with Photoshop CS2, which is what I compressed all the other working jpgs with. It still doesn't work. I tried saving the jpg to a gif in photoshop. It works. Granted, this means I can leave the gif on there and just let it go but... what the heck? Every other jpg saved with the same application works.
  • I did btw try renaming the 'jpg of the damned' - no go.
  • maybe its satan.
  • I found that jpgs created in MS Paint DON'T work on my filebrowser *when placed in a subdirectory*. It works in the root directory.
  • edited September 2005
    But nathan that doesn't make any sense, two files, one made in photoshop and one made in paint shouldn't be different in any way. Unless the paint's jpg converter is botched. There has got to be something wrong with your FB I just tested, my FB install didn't have any trouble showing and thumbnailing any paint jpg files, subfolder or root.
  • well... I give users on my site ftp access to the filebroser. There are a few users that take screen grabs and export them from MS Paint. Those files, and those files only don't work. I can't explian it. They just don't appear. The FB does not see those files as being images. ??
  • Well, umm... I have been on the graphic design business for a while now and never have I heard such a thing, the paint jpg compression is bit harsh but still, it shouldn't be a problem. And my guess is that FB doesn't see if the file is image or not, it makes up it's mind judging by the file extension.
  • Um... So have I. I have no idea why it is doing it, but it is doing it, and only on MS Paint files.
  • another question about the thumbnailer -

    is it supposed to thumbnail .bmp images?
  • edited September 2005
    I'm not sure if GD2 library supports BMP format since it is mainly made for web development, BMP files are not so common on web site, for obvious reason of them being literally huge. Oh, and the GD2 lib is open source and bmp is Microsoft's format, two things that just don't mix.
  • FWIW, I'm having a similar problem. No sub-dirs are involved, but I have two gifs that refuse to be thumbnailed. I have tried re-exporting the files with no luck.
  • I cant get any of my thumbnails to appear... "Preview Unavailable"
This discussion has been closed.