Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Login problems after moving to new domain

edited October 2008 in Vanilla 1.0 Help
I moved my forum to a new domain and had the same problem (white screen) as mentioned in the other post. In the end I ended up creating a fresh install of vanilla, fresh installs of the add-ons and custom mods (Luckily I always back things up on my HD). Then Exported each LUM_ from the database and imported them into the new database. Moved the discussions back into the proper categories and it looks great. Unfortunately for some of the members their usernames and passwords won’t log them in. And those members are not even able to sign in creating a new user name (wrong user name or password). It was working fine for myself even though some of the members were telling me it wasn’t working, then suddenly it happened to me as well. I logged out, then tried to log back in and saw it for myself. Requesting a password change doesn’t even cure the problem. So… I deleted Lum_user from the database and re-imported the file again. Poof, the problem (for me anyhow seems to have been cured for now). I’m not sure how many members are effected and I’ll have to wait to hear if they get in or not. Anyhow I’m certain some action caused the problem such as a new member joining or something, and I’m 99% sure it will happen again. The only thing I can think of is that the database Lum files that I copied were from version 1.1.4 and the fresh install on the new domain is 1.1.5. Maybe Lum_user is somehow different in .5 than in .4? Does anyone know what might be causing this problem? Thanks in advance.


  • Okay it’s happened again, so I’ve carefully looked over the Lum_user file that I have to keep re-uploading (The one that worked fine at the old domain using 1.1.4), and works at 1.1.5 until it gets replaced by the new one that doesn’t work. I wont post the entire strings as someone might be able to decode the passwords, but have a look: A line from the “old” working one: (1, 4, 1, NULL, 'Administrative', 'User', 'Prometheus', 'ff6fa720d5fc6eb8554347**********', '2ad0a609a192ee602fcfab**********', NULL, and so on… Get’s automatically replaced by: (1, 4, 1, NULL, 'Administrative', 'User', 'Prometheus', '$P$B1RZPE3xBAnrvl9eQyw**********', '2ad0a609a192ee602fcfab**********', NULL, and so on. This happens to the entire table so I assume no one can log in. The second string of chars remains the same (I assume that’s the encoded password). But the first sting of chars changes to something entirely different and it prevents anyone from logging in. Please help!
  • edited October 2008
    The type of the password field has changed in Vanilla 1.1.5 from Char(32) to Varchar(34):
  • edited October 2008
    Thank you for the reply, but what can I do about that so that my existing members can continue to log in? It’s odd, because this happens to new users attempting to sign up as well. Creating a new username and pass gets you in one time, but after signing out it’s all over.. Is there something in one of the Lum files that I need to change to be compatible with 1.1.5? Edit: Just saw the link, I'll see what I can figure out. Thanks again.
  • Problem solved TYVM!
  • You are welcome.
This discussion has been closed.