Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Changing URL from localhost to...

edited October 2008 in Vanilla 1.0 Help
Hi everyone hopefully this is an easy one for some of you php apache gurus out there. I am running vanilla(latest version) on a XAMPP lite box. setup was done with these directions and everything seems fine. Except now I want to change the URL to something you know not localhost/vanille. So I have found this post and followed "Mark Oct 18th 2006" post regarding the conf/settings.php modifications. This works fine and for the base URL but all of the other pages fail like catagories or validated_users_url. Is there another config file that needs to be changed for everything else to resolve now? Thanks for any help out there.


  • Options
    OK so I went back and just tried something which seems so easy under settings/Application settings I changed the "web path to vanilla" to my desired domain name. In comparing the 2 conf files the one I manually changed and the one modified via settings/application settings and the only difference is that the $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://localhost/vanilla/'; on the one modified by settings/application settings left the localhost/vanilla as above. Does not really make sense to me but I had chaged that validated_user_URL URL to the newly defined URL in the manual change. Hope this makes sense to someone more savvy then me or helps someone in the furture.
  • Options
    edited October 2008
    After updating the following settings everything should work find (except maybe the styles):
    $Configuration['DEFAULT_STYLE'] = '/Vanilla/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/Vanilla/'; $Configuration['BASE_URL'] = 'http://localhost/Vanilla/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://localhost/Vanilla/'; $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/Vanilla/';
  • Options
    If Vanilla was at http://localhost/Vanilla/ and is now at htttp://, the settings should be:
    $Configuration['DEFAULT_STYLE'] = '/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/'; $Configuration['BASE_URL'] = ''; $Configuration['FORWARD_VALIDATED_USER_URL'] = ''; $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/';
  • Options
    OK so I have gone back and tried making those exact line changes with no success, any other ideas? Sorry if I left this out and it makes a difference but I am just resolving all this via a host file? I have not stepped into the DNS world yet. In addition I am making the changes in notepad and saving the encoding is ANSI? Not sure if that makes a difference either. Thanks for the help!!!
This discussion has been closed.