Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Found a hick up ?

Hi all, I just noticed something important to me. My forum will be dealing with Japanese antiques and we use Kanji quite a lot. When I add Kanji like this 日本刀美術部 I just get ?????? question marks. Other forums have required me to use HTML in my posts', would the same apply here and is there an extension I can use for this ? Cheers Richard

Comments

  • Options
    edited November 2008
    Just as a note, I see the Kanji posted here so I am not sure what I am missing in my forum ? Also, I can see it in my previews, but not in the post ?? cheers Rich
  • Options
    I think you need to refer to the Character Encoding section of the documentation.
  • Options
    Trying that but I am either not getting it or it is not working ? Cheers Richard
  • Options
    I think perhaps you're not getting it or missing some part - as far as I know it's worked for everyone else. Could you run through it and write up your various settings (forum char encoding, database char encoding, whatever else) on here and maybe one of the resident charset experts can glance over it and see where you may be going wrong?
  • Options
    edited November 2008
    Hi there, sorry but I am not too code savvy and do not understand what you mean. I am suspecting it is a mod of some sort, I also tried various Styles and Themes last night and now my images that I uploaded have disapeared and new images will not show. I can see the kanji in the preview, but not in the post ?? Getting a bit confused now Richard
  • Options
    Can you tell us what character encoding you are using for your forum, connection, and database as per the information here: http://lussumo.com/docs/doku.php?id=vanilla:administrators:encodings ?
  • Options
    Hi have tried both UTF-8 and Shift-JIS but to no avail. Another issue I have noticed is that I cannot seem to have both UTF-8 (or Shift-JIS) and get to use extended characters like ô to work. This has been pretty straight forward in other software like PunBB ????? Cheers Richard
  • Options
    How is this forum set, is it the HTML extension that allows this ?? It all works here. I think I am going to reinstall my forum for starters and start again. Richard
  • Options
    edited November 2008
    ok, reinstalled, started from scratch, no joy, Any idea anyone ???, is there anything I can share to get some help ? do I need to move on to anotehr package. I don;t want to spend days and days trying to work out something that should be simple to set up Cheers Richard
  • Options
    The formatter shouldnt affect anything to do with which characters you can use. This forum will be set up so all encoding methods are set to UTF-8 as recommended. Unfortunately without more knowledge on my part and without being able to dig around your server I'm at a slight loss what to recommend for you as I dont know which part is causing the trouble.
  • Options
    What is the encoding used in your database; In PhpMyAdmin and in the list of table what are the values in the collation column?
  • Options
    edited November 2008
    What is probably happening is that your database doesn't store the comments using the same encoding than the one used by vanilla and have to translate them before storing them. The characters that can't be stored using its encoding are converted to "?". There is a discussion opened about that in the bug-tracker: http://lussumo.com/bugs/discussion/112/vanilla-installer-should-set-the-tablesfields-encoding/ Here is a build of vanilla including the last changes. It should set the charset of the vanilla table to utf8 when creating them. http://dl-client.getdropbox.com/u/83967/vanilla/vanilla-1.1.5-2r771.zip If you need to keep your old table, see documentation about converting your database to utf8: http://lussumo.com/docs/doku.php?id=vanilla:administrators:encodings#cleaning
  • Options
    Thanks Dino :)
This discussion has been closed.