Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Help with upgrade from 1.1.4 to 1.1.5a

edited December 2008 in Vanilla 1.0 Help
hey, this morning vanilla made me check for updates and damn, it found one (1.1.5a). damn because i was really happy when it all worked just the way it was, but i already knew the day would come when i had to update 1.1.4. so first i go to and watch the "upgrade video", but compared to the upgrading instructions text i dont have to do anything like this because my version is newer than 1.x. ok, so i try to follow the upgrading instructions: i download the new zip-file, unzip and replace all the files named in the instructions. then i try to visit my forum and - a blank site. no idea what happened. bless god i had my 1.1.4 backed up (i was near committing suicide) so i just uploaded the copy and it worked again, but now i still run 1.1.4. do you have any ideas what i did wrong? im using my own css theme (changed footer) if that could be a problem. or do i have to upgrade to 1.1.5 first, then to 1.1.5a? i'm very thankful for any suggestions or hints, thx!


  • Check this comment: As far I know 1.1.5 did only break Private Message (it needed a bug that 1.1.5 fixed). Alsoe, if you have customized theme you will have to update themes/yourtheme/menu.php:
  • edited November 2008
    Thank you for instructions, but unfortunately it just doesn't work! :I First of all i switched to the default vanilla theme, so i can be sure it's not because of my customized theme. Then again i started my ftp program and uploaded the files of the upgrade packages - and again a blank white site where my forum should appear. Then copied back my old files and it worked again. After that, i downloaded the complete version 1.1.5a again and uploaded only the files named in the upgrade instructions. I did this and checked my forum after every file. I noticed it's blank from the moment i copy the files in the appg folder. Do you have any idea why this happens? I don't have to do anything else? Just upload the new files and that's it? There's a friendly looking upgrade site in the setup folder, but it says only use this if you're upgrading from 0.9.x and i already have 1.1.4. So i guess i just have to get the new files and that's it. But it doesn't work...i appreciate any hints, thx!
  • edited November 2008
    You should all the file at the same time. You try to turn on the display of error message to know what's the problem:
  • edited November 2008
    Hum, i checked some cgi error log and have multiple warnings like: "PHP Notice: Undefined property: LanguageSelectorArray in /home/www/forum/extensions/LanguageSelector/default.php on line 84/87" Looks like it has sth to do with the laanguage selector extension. I'm kinda sry for asking like a noob, but looks like i'm not fit enough for a vanilla upgrade where you have to think about so much more like theme, extensions and stuff. Can't i use some kind of upgrade walktrough just like the one when i installed it? That was so i kinda feel lost cause i'm no php pro and need a lot of time to fix some code. Still i'd like to stay with vanilla, it's slim, fast and valid!
  • Remember that with this extension, you need to path vanilla: Try to update and patch it.
  • Thx to your hints, I was able to remember the LanguageSelector Add-On core hack thing. Of course, 'the one line' didn't exist in the updated appg/init-files. I added the line and also updated the menu.php in my customized theme folder. And now it works fine! Right version displayed and no errors, perfect! Thx a lot for your help! Even if Vanilla only has a comparatively small community, as long as you bother about every single guy so well, it's at least as strong as the others.
  • Any idea why my "Subscribe" feature isn't working on my forum any more? It sends users to the Forum home page. It doesn't even work to subscribe in my profile. I use the Notify 1.2.1 plug-in (my forum
This discussion has been closed.