Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Configuration problem

edited December 2008 in Vanilla 1.0 Help
Hi, I am a newbie to Vanilla and MySQL, although i some experience using PHP. I just installed MySQL and it fails at the point where configuration is is executed. The Prepare configuration, writing configuration and Restarting service checks out, but "Apply security settings" step fails with error number 1045, saying "Access denied for user 'root'@'localhost' (using password: YES)". What i don't understand is that first, there is no root account on this computer there is only one account is the Administrator.Also, i don't get the point of the configuration asking a current password and new password. What password, the password to the Administrator account which i am trying to use vanilla from which is the current user. I tried both the current password and the new password are the same and i still get the same result. Also, i tried it with the anonymous account only. And when this passed, the mysqladmin create command would not work. i had to uninstall mysql and re-install and i got the same thing. The first time i installed mysql, i didn't have this problem but something else did not work and that is why i re-installed. Any help to clarify this is appreciated. thanks, Bramoin


  • That's a MySQL error and it means the password is wrong. You may need to configure MySQL first by creating a MySQL user that Vanilla will use to communicate with the database and also creating a database to store the tables that Vanilla creates.

    MySQL setup needs to be done before you try to setup Vanilla. The best/easiest way to set up MySQL is to use phpMyAdmin.

    If you're on a hosted server, you may want to first see if phpMyAdmin is already installed.
  • I was able to get past the configuration issue by uninstalling MySQL and then deleting the directories both the data directory and the one in the program files. Then reinstalled and the configuration went by like a breath. But now, i am back to the point where i need to install Vanilla and i am at the point where it asks me for the MySQL database server and i entered "localhost", then it wants a database name, but i don't have one. So, i opened up command prompt and typed in "mysqladmin create tendaltiforum" but this is what i get: C:\Users\amp>mysqladmin create tendaltiforum mysqladmin: connect to server at 'localhost' failed error: 'Access denied for user 'ODBC'@'localhost' (using password: NO)' I have PHP5.0 installed. Why am i getting this error? thanks, Bramoin
  • edited December 2008
    You should try to use xampp to install apache and mysql on windows. It will come with phpmyadmin to manage mysql which should be far easier.
  • edited December 2008
    If you want to use mysql command line tools, you should know that MySQL has its own authentication and authorisation features. It comes with one default user named "root" without password with all permission on you tables. You should not use it for production, but for development it is ok.

    However Vanilla needs a user that has a password, so you should start by giving a password to your root user:mysqladmin -u root password aPASSWORD

    Then create the database:mysqladmin -u root -p create aDATABASENAME

    When installing vanilla, you should use root and its password for the user and password field.
  • After i create the database with "mysqladmin -u root -p create aDatabasename", do i need to create any tables or does the vanilla configuration does that?
  • i was able to use the "mysqladmin -u root -p create tendaltiforum" to create the database but i still get this error from the vanilla install: We connected to the server, but we couldn’t access the 'tendaltiforum' database. Are you sure it exists and that the specified user has access to it? What do i need to do now to set up a database forum or does the vanilla install does the rest?
  • Vanilla will create the table.

    In "mysqladmin -u root -p create aDATABASENAME" you should replace "aDATABASENAME" by the name you want to use for vanilla.
  • i have. as you can see, the database name is called "tendaltiforum". I downloaded the GUI tools and i created a connection and then try to use it and still get the 1045 error. Why can't you guys make a product that work with something that uses windows authentication like MS SQL does. This is so ridiculeous. i think i will switch my focus to PHPBB. Hopefully, i will not this issue with that product.
  • i was able to connect to the database using the MySQL Query Browser tool as root. so, now i can see the database "tendaltiforum". What is the next step in setting up vanilla?
  • Aha, i used the vanilla configuration and it is still at the point where it tries to connect to the database and here are the enteries "MySQL Server is set to localhost", Database name is set to "tendaltiforum", the username is root, the password is the password for root. the prefix is LUM_. But eventhough the Query Browser tool logged me in and i can see the database, the vanilla configuration wizzard tells me this: "We connected to the server, but we couldn’t access the 'tendaltiforum' database. Are you sure it exists and that the specified user has access to it?" what do i need to do to get past this? Please....
  • Good news! I found out that the database name was wrong, when i created it, i was missing a letter in there. Sorry, i feel like i owe someone an appology.
  • Wohoooo, i got it working.!!!!
This discussion has been closed.