Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

new guy problem: not recognizing new user

edited December 2008 in Vanilla 1.0 Help
Okay, so yesterday I downloaded vanilla 1.1.5 and installed all the extracted files to a folder on my server called "forums". My server/host is ipower, by the way. I created a sql table called vforum, then input all of the table information into the vanilla install. Everything worked flawlessly. I was then asked to create a username, password, and e-mail, which I did. Again, this all worked fine. So now it says "you're ready to go" and when I click the link it tells me to sign in. I input the user name and password, and it takes me to the forum main page, but no options are available, and up at the top right hand corner it says "sign in" still. Is there something I've missed in the installation instructions? Any help would be appreciated. Thanks!


  • Options
    If you changed anything in the cookie settings near the last step, then delete the .php files in the settings folder and that will let you run through the install again. Try keeping the cookie fields on the default settings.
  • Options
    edited December 2008
    I never saw an option for cookie fields during the install. It was just 1) Input sql database info 2) create a user name and password 3) log in, but it wont...? edit: nevermind, I see what you mean now. I input the domain in the cookie field, and in the sub-field I entered the forum folder that the vanilla files are stored in, and it still doesn't work. Am I putting the cookies in the wrong place?
  • Options
    update: I tried a fresh installation again and it installs fine, but same problem. I log in with the account I created, and when it goes to the forum mainpage it just says "not logged in(sign in) in the top right hand corner. I let the install pick the cookie path by default, and made no changes whatsoever. note: I'm installing this on a wordpress blog. I didn't mention that before. are there issues with installing to wordpress or on an ipower server? I made a separate sql database for the forum, I'm not trying to merge it with wordpress or anything.
  • Options
    Update: I fixed the problem, I hope, but for now the forums are at least working. This needs to be addressed in the installation requirements. ipower, one of the web hosting services, requires you to enable php sessions in order for vanilla to work on their servers. Once this is done, vanilla works flawlessly, until this is done however, vanilla will install perfectly, but then not actually let you sign in, even though it accepts the user name and password. There may be a code workaround to the php session issue, but I found the other thread where the ipower user was having the same problems, and tried pasting the enable session path code to my installation, and it DID NOT work. Once I contacted ipower and had them enable sessions though, a fresh installation worked perfectly. just FYI, ipower is a pain in the ass.
  • Options
    Do you still have the URL of the thread where you found the solution so others can benefit? :)
  • Options that's the thread on this forum where someone else was having problems. I tried using the session save path code that was provided, but it did not work. I got into an instant help chat window this morning, told them I needed to "enable php sessions" to run forum software. They said php was enabled, to which I replied "I know, but I need php sessions enabled, please do this." The guy came back five minutes later and said he created a session path. I then reinstalled all vanilla files to my forum folder, ran the install, and it works great! I love the vanilla forum software so far, but this was very aggrivating, because the code is so easy to install, but ipower makes it so difficult.
  • Options
    This problem occurs if you have PHP4 enabled (as opposed to PHP5). I am running on MediaTemple, and switching from 4->5 fixed the issue. Jeremy
This discussion has been closed.