Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Cookies across a site

edited January 2009 in Vanilla 1.0 Help

I've been working on this cookie problem for awhile, and beign relatively new to this world of cookies, I think I must be making an obvious mistake.

My site has a vanilla forum and a main section (custom php app for articles being posted). If I log in through the main site, and go to the forums, I remain logged in.
If I log in through the forums, then decide to go the main site, my login to main site becomes "".

So I guess essentially I have the cookie system working one way, but not the other...



  • Options
    You probably need to make sure 1) Your custom app is checking cookies for the proper domain ( is different from and 2) Your custom app is checking for the right cookie.

    Vanilla is pretty flexible in terms of names of cookies. The following configurations deal with that:$Configuration['SESSION_NAME'] = ''; // Defaults to PHPSESSID $Configuration['COOKIE_USER_KEY'] = 'lussumocookieone'; // "Remember me" cookie $Configuration['COOKIE_VERIFICATION_KEY'] = 'lussumocookietwo'; // "Remember me" cookie $Configuration['SESSION_USER_IDENTIFIER'] = 'LussumoUserID'; // Session Variable storing the User ID $Configuration['COOKIE_DOMAIN'] = ''; // Cookie domain $Configuration['COOKIE_PATH'] = '/'; // Cookie Path If your forum is in a subdomain of your main site ( and, make COOKIE_DOMAIN "" (leave out the sub-domain part). Try playing with these configurations and see if you can narrow down or fix the issue.
  • Options
    hi i havea similar issue ithink...ive looked around this seems the right place to post.( a little gun shy about posting, after getting much flack on prior if i m in wrong area pls forgive)
    - i have my main site as a wordpress site at:
    (physcially its located at
    and my vanilla forum at :
    which now goes to error/notfound:

    since upgrade , have to manually put the url as:
    to access the forum (if not logged in.-if you are logged in its ok)
    what might ichange to stop the conflict ?
    i have the app settings for cookie domain as
    should i change it to:
    sorry - i keep breaking the board and im pissing off some pretty knarly fans/emembers ..any suggestions ?
Sign In or Register to comment.