HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

do not have the ./extensions folder

edited December 2008 in Vanilla 1.0 Help
I am trying to install vanilla. But when it comes to setting the permissions for the different folders, I am stuck. I do not have the ./extensions folder in the latest version of Vanilla(1.1.5a). All the other folders whose permissions are to be changed are there (./conf, ./languages, ./setup, ./themes). What could be the problem? Please help. Thank you.

Comments

  • Just make the folder
  • Thank you. So is there no default folder called './extensions'? Do I just create an empty folder?
  • Well yes there is a folder called extensions; the folders that are in the root folder are as follows:

    ajax
    appg
    conf
    extensions
    js
    languages
    library
    setup
    themes

    But the extensions folder is empty by default, so just creating an empty folder called extensions will be ok. It doesn't explain why it wasn't there in the first place, but it shouldn't matter.
  • Thank you. Yes, I do have all the other folders, but strangely the 'extensions' folder was not there. I had checked all the available material regarding this, but could not figure out why. Anyway, thanks to you, I created the empty folder and was prompted to the next step. But I am stuck here as well. When I try to create mysql database, it says cannot connect. I am new to all these and hence it is taking me a lot of time to figure out the problem.
  • You have to create the database before you run the Vanilla setup. The Vanilla install can only connect to an existing database, not create one.
  • Thank you. I did that, but I still have problems connecting to the database. It says "access denied to 'root'@';localhost' using 'password:yes' ".
  • It's possible you need to use something other than localhost. Are you using a webhost? If you are, try to find a FAQ or contact them to ask what you should put there.
  • Thank you. Yes. I am using a webhost. I contacted them and they gave me my account details. They asked me to give the server as 'localhost'. I then created a database and granted the privileges to my webhost user account, through my windows command prompt. (Actually they have a provided a phpMyAdmin tool, but when I tried to use that, the 'create database' section said 'no privileges'). Then I try to prceed with vanilla installation using these details, but I get the following error : "We connected to the server, but we couldn’t access the 'freshvanilla' database. Are you sure it exists and that the specified user has access to it?" How do I resolve this? Thanks in advance.
  • Well it seems like phpMyAdmin is telling you the same thing as Vanilla is. The account doesn't have enough privileges to create and/or access the database.
    Unfortunately there isn't a lot I can do; web hosts have completely different settings and ways of doing things, and they (necessarily) lock shared users out of many settings.
    My best advice is to ask them for more complete instructions on how to create a new database and which details to use when connecting to it. You need 4 things: database name, username, password and server. They've already told you the server is localhost which is normal, when you have created the database I guess it will be called freshvanilla, and the username will possibly be the name of the database again. It just depends how they configure their servers, they will know.
  • Thank you. I was finally able to complete the vanilla installation. Actually my webhost had created a database for me. I did not understand that. It was my mistake. They had sent me the database name they created and the username and password for that. I was under the impression that I could create my own database, which was what I was struggling with. Finally I figured out that I had access to only that one databse they had created for me. Anyway, thanks a lot to you, I could finally complete the installation.
  • Ah cool, yeah that's not uncommon for webhosts :) Hope you enjoy the new forum!
  • Thank you, once again.
This discussion has been closed.