Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

setup problem

edited January 2009 in Vanilla 1.0 Help
I just had vanilla setup on my VectorLinux box with apache. However, when I click "Sign In", it says "The requested URL /vanilla-1.1.5a/people.php was not found on this server." I have vanilla installed in /home/public_html/domainname/vanilla-1.1.5a in which I can see the file people.php. the VirtualHost in vhosts.conf has: DocumentRoot /home/public_html/domainname/vanilla-1.1.5a What is the problem? Please help. Thanks.


  • In vhost.conf, you have specified
    DocumentRoot /home/public_html/domainname/vanilla-1.1.5a
    as the root of Vanilla.
    That should be
    DocumentRoot /home/public_html/domainname
    (now, Vanilla tries find people.php in the directory
    DocumentRoot /home/public_html/domainname/vanilla-1.1.5a/vanilla-1.1.5a/
    which does not exist)
  • Thanks for your reply. When I try your advice: DocumentRoot /home/public_html/domainname It shows the contents of the "domainname" folder including /vanilla-1.1.5a, instead of the forum. There must be another setting somewhere I have to change also? Thanks.
  • if I use http//domainname/vanilla-1.1.5a/index.php in the URL, it works just fine.
  • I added in .htaccess: DirectoryIndex vanilla-1.1.5a/index.php and that does not help?
  • edited January 2009
    try this: remove that .htaccess file and change docroot back to what you posted originally, restart apache and access: http://domainname/ (without /vanilla-1.1.5a) and it should work
  • Actually, it documentRoot contains /vanilla-1.1.5a, "Sign In" will try to locate people.php in /vanilla-1.1.5a/vanilla-1.1.5a and it will fail. If I documentRoot does not contain /vanilla-1.1.5a, http://domainname will show list of folder (domainname) contents, while http://domainname/vanilla-1.1.5a/index.php will show correctly. However, login fails because "user name password combination not found. adding .htaccess does not have any effect at all..??
  • Ok. the reason I cannot login was because i did not pass the cookie path. Still though i cannot make http://domainname go straight to domainname/vanilla-1.1.5/index.php Even 301 redirect in .htaccess does not make any difference?
  • Ah, I did not realise that that's what you're after.
    In that case, you would have to maintain
    DocumentRoot /home/public_html/domainname/vanilla-1.1.5a
    in Apache's vhost.conf, and specify
    $Configuration['WEB_ROOT'] = '/';
    In your conf/settings.php in vanilla.
  • It's getting better - but still need a little more help.. I changed the DocumentRoot and WEB_ROOT. At the same time, I had to change a few things in conf/settings.php. Now I get the default themes, and I am able to login. However, after I login, the theme is lost again. I have tried to change the paths in the file, but I still do not have a theme. (I am able to logout, i.e., the links work.) Below is my settings.php. Is there anything wrong? (the paths of database.php, library, extensions, languages are correct.) $Configuration['APPLICATION_PATH'] = '/home/public_html/domainname/vanilla-1.1.5a/'; $Configuration['DATABASE_PATH'] = '/home/public_html/domainname/vanilla-1.1.5a/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/home/public_html/domainname/vanilla-1.1.5a/library/'; $Configuration['EXTENSIONS_PATH'] = '/home/public_html/domainname/vanilla-1.1.5a/extensions/'; $Configuration['LANGUAGES_PATH'] = '/home/public_html/domainname/vanilla-1.1.5a/languages/'; $Configuration['THEME_PATH'] = '/home/public_html/domainname/vanilla-1.1.5a/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/'; $Configuration['BASE_URL'] = ''; $Configuration['FORWARD_VALIDATED_USER_URL'] = ''; $Configuration['SUPPORT_EMAIL'] = '[email protected]'; $Configuration['SUPPORT_NAME'] = 'Site Name'; $Configuration['APPLICATION_TITLE'] = 'Site Name'; $Configuration['BANNER_TITLE'] = 'Site Name'; $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/vanilla-1.1.5a/';
  • Sorry, I made a mistake.
    You want to make http://domainname go straight to domainname/vanilla-1.1.5/index.php
    That means that your webroot should be:
    $Configuration['WEB_ROOT'] = '/vanilla-1.15/';
    I suppose that your theme will work fine after you have changed this entry.
  • if I change WEB_ROOT to vanilla-1.1.5a, I will not be able to login again because it tries to find people.php in /vanilla-1.1.5a/vanilla-1.1.5a and fails.
  • hmm.. apparently, it's supposed to be themeless until i first login and choose and save the default theme! It looks like it's working now. Thanks for the help.
Sign In or Register to comment.