Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

GoDaddy permissions trouble

I am in the middle of trying to add Vanilla to my GoDaddy hosted site...I am running into an error on Step 1, the /conf files are not being added (settings.php, langauges.php, etc.) Has anyone ran into this problem, or can you offer some help... I built my site with Dreamweaver in design layout mode and know very little about code or working with give me a break. Thanks, Nick


  • here is the text: Failed to create the 'd:/hosting/nickcaliva/vanilla/vanilla-1.1.5a/conf/database.php' configuration file. Failed to create the 'd:/hosting/nickcaliva/vanilla/vanilla-1.1.5a/conf/extensions.php' configuration file. Failed to create the 'd:/hosting/nickcaliva/vanilla/vanilla-1.1.5a/conf/language.php' configuration file. Failed to create the 'd:/hosting/nickcaliva/vanilla/vanilla-1.1.5a/conf/settings.php' configuration file.
  • Go into your hosting contrl center at GoDaddy.. select your vanillia conf 'folder'.. then select the 'permissions' tab at the top of the file manager... when the window opens deselct the fist box where it says 'inherit' permissinos of parent directory (or something lke that).. and make sure the next three choises are 'selected'.. read status checked, write status checked, and 'children' inherit permissions of this directory (or something like that) okay, and then try again.. see if it works now..

    If you have problems in the future, do this for whatever folders you think might be having problems.. One of the issues with GoDaddy, is that it automatically sets all the files to inherit the permission of the directories they are in.. not neccessarily a bad thing.. just something to keep in mind..

    one other thing.. you can not set the permissions of individual 'files' in GoDaddy.. you can only set the permissions of 'folders' (directories)..
  • edited January 2009
    I tried that....and still nothing. Same failure, even tried to make the whole site read/write and inheret...any other ideas?
  • Did you set up a database, and properly target it?

    whenever you set permissions, make 'sure' that the 'inherit the permissions of parent directory' switch is 'deselected'.. That is what was causing me the same problem when I set it up.... it's selected by default, and will prevent your permissions from being applied as it keeps getting it's permissions from the parent....
  • Hi I am having trouble with installing Vanilla on my Godaddy hosted site too. Everything appeared to install fine, and I went through all the steps, but when I access my forum, it is not working properly I can see the main page, which of course has no discussions on it yet. I can only see 3 tabs at the top "Discussions", "Catagories" and "Search" When I click Catagories or Search, I get an error "Connection Interrupted" page error. I can access the page where I sign in, but when I try to sign on or create a new user account, I get the same "Connection Interrupted" page error... Any ideas???
Sign In or Register to comment.