Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Broken mimetypes on

edited January 2009 in Vanilla 1.0 Help
See screenshot.

Because the mimetype is broken, I can't use the "open with" functionality - need to download the extensions first, then double-click in the download window to open.


  • It seems to be setting the Content-Type to "application/download" which I think might be causing the problem. It should be "application/x-zip".

    However, I tried duplicating your problem in Firefox on both Mac and Windows. I was able to use "Open with" correctly. I'll try this on my Ubuntu machine when I get home.

    In your screenshot, it seems to be selecting "Archive Manager" correctly. What happens when you click "Ok"
  • It says "/tmp/Add_On_ PaperTheme could not be opened, because the associated helper application does not exist. Change the association in your preferences.". Could be a Firefox on Ubuntu bug, not sure - it's just slightly inconvenient having to download the file and then open from the archive program (and delete it after) when it can be just opened with it directly and dragged onto the website.
  • I just checked this on my Ubuntu machine and I get the same error as you, it appears to be an error in the implementation of the browser :-/ My best guess at least... Strange, when I go to the file in <tt>/tmp/</tt> I see that it is saved as "Read-Only" (owner read-only even). I don't know if that has anything to do with it, but it's just an observation.
Sign In or Register to comment.