Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

login (cookie) issues with Chrome.

edited February 2009 in Vanilla 1.0 Help
I'm pretty new to vanilla, so excuse my ignorance where it appears :) I've set up vanilla in a test environment so my path to the test version is http://{ip address}/vanilla - all is moving along just fine except I can't login using Chrome. I can login using any other browser (safari, firefox, IE, opera). In chrome I enter the login credentials and just get returned to the login screen - no error is reported. If I enter bogus details I get the error "Some problems were encountered". No cookie is being created (PHPSESSION) which I'm assuming at this stage is the problem, however I'm having some trouble working out how to fix it. The issue is limited to chrome - (Incedentially I'm posting this from chrome, so it clearly works on this instance of Vanilla) Anyway I'm assuming the issue is local and likely to be config based (be it the vanilla config or php/apache config) Any help would be appreciated - thanks in advance A few details... ====================== Chrome version PHP Version 5.2.0-8+etch11 Vanilla version - 1.1.5a config (I've disabled all extensions) $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = '/var/www/vanilla/'; $Configuration['DATABASE_PATH'] = '/var/www/vanilla/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/var/www/vanilla/library/'; $Configuration['EXTENSIONS_PATH'] = '/var/www/vanilla/extensions/'; $Configuration['LANGUAGES_PATH'] = '/var/www/vanilla/languages/'; $Configuration['THEME_PATH'] = '/var/www/vanilla/themes/Vanbook/'; $Configuration['DEFAULT_STYLE'] = '/vanilla/themes/Vanbook/styles/default/'; $Configuration['WEB_ROOT'] = '/vanilla/'; $Configuration['BASE_URL'] = ''; $Configuration['FORWARD_VALIDATED_USER_URL'] = ''; $Configuration['SUPPORT_EMAIL'] = 'xxxx@xxxxxxxx'; $Configuration['SUPPORT_NAME'] = 'xxxx; $Configuration['APPLICATION_TITLE'] = 'xxxxxxxxxxxx'; $Configuration['BANNER_TITLE'] = 'xxxxxxxxxxxxxx'; $Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '/'; $Configuration['SETUP_COMPLETE'] = '1'; $Configuration['DATABASE_VERSION'] = '2'; $Configuration['ADDON_NOTICE'] = '0'; $Configuration['USE_CATEGORIES'] = '0'; $Configuration['LOG_ALL_IPS'] = '1'; $Configuration['PUBLIC_BROWSING'] = '0'; $Configuration['AUTOCLOSE_Limit'] = '28'; $Configuration['AUTOCLOSE_Archive'] = '0'; $Configuration['AUTOCLOSE_MenuTab'] = '0'; $Configuration['AUTOCLOSE_OpenStickies'] = '1'; $Configuration['AUTOCLOSE_OpenWhispers'] = '1'; $Configuration['AUTOCLOSE_OpenCategories'] = '0'; $Configuration['AUTOCLOSE_SETUP'] = '1.3'; $Configuration['NO_SHIT_VERSION'] = '0.2'; $Configuration['NO_SHIT_REPLACEMENT_STRING'] = '****';


  • Options
    Try with these settings:$Configuration['COOKIE_DOMAIN'] = ''; $Configuration['COOKIE_PATH'] = '';
  • Options
    Thanks that works - much appreciated.
  • Options
    i am having similar issues in chrome with vanilla

    i can log in fine with firefox/ie, but for some reason not with chrome. i tried the above advice, but the config file is a little different in the newer version. i copy/pasted the above code as is, and i also tried with it looking like the new config file

    $Configuration['Garden']['COOKIE']['PATH'] = '';

    but still nothing. am i supposed to put my own directory in between the ' ' after ...[PATH]=' ' ? any advice is awesome, thank youuu:)

    ps. this is my last question/problem i swear!
    .....for today :)
  • Options

    Does anybody have an answer for this?

Sign In or Register to comment.