Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.


edited February 2009 in Vanilla 1.0 Help
Trying to get YUI Editor to show up in my extensions list...

I edited the content_form.php and discussions_form.php file as I was instructed (pretty sure I did what I was told)... uploaded the YUI editor and it didn;t show up in the extensions list.. So I thought maybe, it's because there is a folder called 'Build' inside the YUI editor, and all the files are inside that, so I renamed it to YUI editor and uploaded that, still no YUI edtor shwoing up in the extensions list.... tred both again with permissions set ofr the whol folder to read and write.. still nothing....

What is the big secret to this thing?


  • Options
    Make sure you have a default.php file inside the YUI editor folder, which should be inside the extensions folder. If you do or not, it might be a good idea to re-upload that file and see if that makes it appear in the list.
  • Options
    Now we're getting somewhere.. There is no 'default.php' in the root directory of the YUI editor folder, neither on the server, or in the version I downloaded for the link provided..

    Yet there 'is' one in the root directory of every other extension... so where do I get one?

    I'm assuming they're custom for every plug-in, or can I just copy one from any other plug-in?
  • Options
    So I downloaded the file again, and it still doesn't have a default.php file in the root directory.. nothing but folders...

    If you click on the link from the lussumo add-on page, you just get a screenshot gif of the UI.. evidently the file was too large for uploading to the lussumo server, so the person who uploaded the add-on (houseinprogress), uploaded it to 'divshare'...

    here's a link to the actual file
    And here's a link to the lussumo add on page discussing it
  • Options
    Hmm... it is listed in my copy that I downloaded from rapidshare... I'll repackage it as a zip and see if that works for you.
  • Options
    Wow.. There's all kinds of stuff that isn't in the one I downloaded from the link he listed on the add on page..

    There's an image file, the default file, a read me and uploader file or two.... All that was in the root directory of the one I downloaded was that 'build' folder... all of the other stuff that is in your, was missing.. Amn, I've been going crazy trying to get this to work... It never woud have, no matter what I did..

    Thanx, I'm uploading it now to the server.. I'll let you know how it goes...
  • Options
    Well, it works now.. surprise surprise..

    Couple problems though..

    the font/size list opens, and scrolls, but I can not see any contents in the list... same with paragraph style....

    Spell checker is still disabled.. is there one that plays niice.. and vanillacons don't work.. Is there a smilie add on that works?

    The odd thing is, that when I was using Tiny MCE, in the comment reply window, I could adjust text size and color.. but it would not show up in the posted message.. but suddenly, all those posts I made using that editor, now has the enlarged text and colors applied...

    Preview doesn;t work in either editor.. Is there a way to get it to work?
Sign In or Register to comment.