Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Trouble getting own extensions to appear in the management list

edited February 2009 in Vanilla 1.0 Help
Hi all, I've been trying to start building my own extensions but can't seem to get anything recognized in the extension management list. I've followed the guide to getting started in the documentation without much luck. I'm using Dreamweaver and MAMP to edit and test locally. As far as I can tell, the directories and files all have the correct permission settings. I've had partial success getting my default.php files recognized when encoding them as ASCII using OSX's TextEdit and placing them directly in my test server directory. This only works occasionally. When using Dreamwever to upload them they never show up. I've also tried adding echo statements to extensions that I've downloaded. Sometimes this produces the desired results, sometimes it results in the extension disappearing from the extensions list. Has anyone had similar issues? Any insight as to what may be up and how to resolve this would be greatly appreciated. Thanks in advance.


  • Options
    Are you definitely putting the required bits of information in a comment at the top of your extension, naming it default.php, then placing it in a folder under the extensions folder?
  • Options
    Absolutely. I've written the comments from scratch, copied them from other extensions, renamed working extensions, etc. Nothing seems to do the trick. My only brief hint of success came out of generating the files and folders using a text editor and encoding as ASCII. Even then all that seems to be recognized are the comments and extension name, ie: no variables echoed.
  • Options
    Wierd. What OS?
  • Options
    Mac 10.4.11. Weird indeed. I'm gonna try on another machine using the latest OS. I'll post if that does the trick.
  • Options
    Hmmm. Let us know. Make sure your apache user has recursive read access to the extensions folder too.
Sign In or Register to comment.