Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Multiple Forums Prefixes without waiting for the next rev

BenBen
edited September 2005 in Vanilla 1.0 Help
Does anyone know how to change the default forum database table prefix in the current version of Vanilla?
I know this is meant to be an option in the next version of Vanilla, but I have no idea when that'll be.

I only have one database and I want to set up another 2 instances of Vanilla, completely seperate from each other.

Comments

  • find the database.sql file in your vanilla dir and do a search and replace for LUM_ with something different then run the installer.
  • What about when it's trying to connect to the database though?
    It seems like the database.sql just creates the tables.
  • yeah, i'm working on that one.
  • lechlech Chicagoland
    same thing for the database/vanilla.sql, just customize it a bit. Or, hold back a month and wait :D
  • A month! Does Mark know this yet?
  • The vanilla.sql also only seems to create the database, and insert the default entries for roles. What about when it wants to pull information from the database?
    That doesn't seem to be mentioned in either file.

    Where are you Mark?
  • Probably packing for North Carolina.
  • *bump*
  • So you are able to change what the prefix is when you install it, but Vanilla still wants to use lum_ when its getting the info from the db?

    So do the files reference "lum_" ? is that the problem? Open em all up in something that has a find/replace feature for all open documents....like Dreamweaver.

    ? Dunno if thats it, just trying to be helpful.
  • Yes, that is my problem. I was just hoping I wouldn't have to do that...
  • i'd assume theres a single (or couple) of references somewhere. But i could be wrong. It seems unlike mark to spread such a thing over a great number of files without the ability to change it simply.
    Maybe thats why it has to be on his list of things for the next rev.
  • edited September 2005
    I'm not guaranteeing anything, but if you scan to the bottom of Utility.SqlSearch.class.php there's a variable $this->TablePrefix = "LUM_"; - the same is also about half way through Utility.SqlBuilder.class.php - try changing this too and see if it rolls?
  • MarkMark Vanilla Staff
    mini is right. change your prefixes in those two files (SqlBuilder and SqlSearch) and it should work just fine.
  • *hugs for mark. This is a config option next rev, right?
  • MarkMark Vanilla Staff
    yes :)
  • Fantastic, thanks mini.
This discussion has been closed.