Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Google Analytics - Revisted

edited March 2009 in Vanilla 1.0 Help

I've searched this forum and nothing addresses my problem I'm having. I DLed the GA extension, and replaced the code on line 23 as a user instructed on the add-on discussion. Initially I had trouble placing the GA acct number within the code, but now GA recognizes and its in the "Gathering Data" mode. But now its been WELL over 24hrs and I still haven't received any data. I'm far from someone who's well versed in code so was wondering if anyone can take a look at where I enter in the GA acct # and see if I did something incorrect? Here's my code:

//replace this with your google analytics account number, of course $Configuration['GoogleAnalyticsAccountNumber'] = 'UA-xxxxx-x'; //add an array of pages to not analyse if ( !in_array($Context->SelfUrl, array('settings.php')) && isset($Head) ) { class AddGoogleAnalytics extends Control { function Render() { global $Configuration; echo ' <script type="text/javascript"> var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www."); document.write(unescape("%3Cscript src=\'" + gaJsHost + "\' type=\'text/javascript\'%3E%3C/script%3E")); </script> <script type="text/javascript"> var pageTracker = _gat._getTracker("'.$Configuration['GoogleAnalyticsAccountNumber']= 'UA-7157449-1';'"); pageTracker._initData(); pageTracker._trackPageview(); </script> '; } } $AddGoogleAnalytics = $Context->ObjectFactory->NewContextObject($Context, "AddGoogleAnalytics"); $Page->AddControl("Page_Render", $AddGoogleAnalytics, $Configuration["CONTROL_POSITION_FOOT"]); } ?>


  • Options
    Download Nuggets extension, cook a new nugget with the Analytics code and put it in the footer.
  • Options
    Thank you. Didn't think about that. I'll see if it works.
Sign In or Register to comment.