Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Cookie problem after upgrade?

edited April 2009 in Vanilla 1.0 Help

I was about to reply in the login loop thread, but decided that my issue is probably unrelated.

Since upgrading from 1.1.5a to 1.1.6 yesterday myself and all other forum members at my site are having to log in each time they visit the forum. I understand from the release notes that some work has been done on the cookies that Vanilla stores and I'm assuming that this is where my problem lies. Is there a new configuration that I'm missing that I perhaps need to change?

I've tried tinkering with the 'Cookie domain' value in the Application Settings to no avail (I'm certain it was right in the first place, just wanted to rule it out before posting here). I've also tried switching my forum back to the default theme just in case it's being caused by an un-patched file from my modified theme folder, but that doesn't seem to have helped either.

Is anyone else experiencing the same problem? All suggestions welcome.


  • Options
    Do you mean that they can't log-in or that the remember me option doesn't work any more? Which version of php are you using? Which add-ons are installed?
  • Options
    ps: the new cookies settings are off by default in in 1.1.*.
  • Options
    edited April 2009
    They can log in, but the remember me option doesn't seem to work any more.

    I've personally deleted the cookies for my site to ensure that new ones are created (they are), but I'm still asked to log in each time I close the browser and revisit the site.

    PHP version is 5.2.6-1+lenny2

    Extensions currently enabled are:
    • Attachments 2.1
    • Category Jumper 1.0
    • Html Formatter 2.3
    • Legends 1.0
    • Make It Simple Text Formatter 1.12
    • ModTools 0.06.10b
    • Multi File Upload 1.1
    • New Applicants 1.3
    • Notify 1.2.1
    • Page Manager 2.5.3
    • Poll 1.3
    • Preview Post 2.5.2
    • Quotations 1.5
    • SoftWrap v5
    • Spoiler 0.3
    • UserAward 1.4.1
    • Who's Online 1.2
    I'm using the Game Press White theme for Vanilla, but as mentioned earlier have tried reverting this back to the default Vanilla theme with no change.

    I'll try disabling all the extensions to see if it solves the problem. EDIT: Disabling extensions hasn't helped.

    Thanks for taking the time to look at this.
  • Options
    Here is diff for people betwenn 1.1.5a to 1.1.6:
  • Options
    Thanks. I'll go and double check that I got all the right files updated.
  • Options
    I clearly must have missed something when I followed the upgrade instructions (not sure specifically what though). I just replaced my entire forum folder with the 1.1.6 release and then used the upgrade path in the setup process to use my existing database. Now my 'remember me' function seems to be working properly again.

    All that remains is for me to put my extensions and themes back together which shouldn't cause me too much of a headache.

    Thanks again for the help Dinoboff.
Sign In or Register to comment.