Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

Login / Sign in redirect url problem (becomes http://://www etc)

edited July 2009 in Vanilla 1.0 Help
I have a problem with the sign in function.
I've been searching and reading the forum for some days, trying to figure out if it was a common and resolved issue, but I found nothing.
So, here it is:

sometimes (randomly) when I sign in my Vanilla forum it redirects me to the wrong url.

When it works properly I sign in and be redirected to
http://www.mysite.com/forum/categories.php

but instead when the problem happens it adds a :// in between and I land on a blank page located here
http://://www.mysite.com/forum/

Of course there's no page there, because that's not a valid url!
How do I solve this?
Is it a ReturnUrl problem? What can I do?
Or should I look for SAFE_RETURN_URL? (I tried to replace it, but then I couldn't sign in at all).

Thanks for helping me.

P.S. If I mispelled something it's because I'm italian.
Also, I'm new to Vanilla, but I am absolutely inclined to open and explore conf and setting php files, so if the solution is something even a little bit complicated, no problem, I'll do it because I need to fix this before I can properly use my forum.

Comments

  • This is similar to a problem I'm having, Francesco. I've described it in greater detail here:

    http://lussumo.com/community/discussion/9471/redirect-url-including-localhost/#Item_1

    No fix yet. I've contacted my hosting company to see if there may be an issue similar to what others have described while using GoDaddy. Will let you know if I hear something that could help.

    Matt
  • Thanks a lot.
    I changed the HTTP_METHOD in conf/settings.php file and it seems to work for now.
    I hope the issue is gone for good. :)
  • This bug also shows up when clicking on the Top of Page link on a discussion page.
  • My sign in URL is : http://mydomain.com/people.php?ReturnUrl=/people.php?ReturnUrl=/people.php?ReturnUrl=http://mydomain.com/

    My HTTP_METHOD is correct, don't know what to do here 0_o
  • I've come across this problem on my local dev setup (MAMP, like LAMP but on a Mac).

    By repeat install/removal of all from the db to the files, I've worked out what I think is the problem (not the answer, sorry, not that clever ;) Here's the sequence:

    1. To be sure, post expand of the ZIP and post creation of the db but pre-install script run, I check the /conf folder and it's 777 (good I think).

    2. Run install and upon arrival at step 3 of 3, I note the /conf folder now has some auto-gen'd .PHP files. The files have permissions of 644 (rekon they should be 777?) but more importantly, the Group/Owner setting is good for Group but 'wrong' for Owner. In my system, files are set to Owner 'alan' and these files are set to Owner '_www'.

    3. I hand set the Owner on the files back to 'alan' and then set all files in /conf to perms of 777.

    -- pause to note
    I think 1. through 3. above are a problem in their own right (maybe a problem with my setup, not Vanilla) -- my setup, I run on a normal user login (not an Administrator login) and my webserver (MAMP Pro) runs on an Administrator login -- it has to to work. Don't know if this is helpful to know.
    --

    4. I login and all ok. I logout and back in and always OK, over and over. Close the browser and open it again and login and I get the malformed URL with the extra :// in.

    5. I hand edit the URL in the address bar and I login fine, I can now login and out over and over, no problem. If I close the browser and open it again and login, I get the :// problem again.

    6. I open /conf/settings.php and hand edit
    $Configuration['HTTP_METHOD'] = 'http://';
    to
    $Configuration['HTTP_METHOD'] = 'http';
    save and quit the browser and now I can login, close the broswer, open it and login, no problems remain.

    Foot note: Coda, my editor, highlights what it sees as non HTML/code content, and when opening the settings.php file, it highlights to 'hard carrige returns/paragraph markers' where I've added an 'X' below:
    <?phpX
    // Application SettingsX
    assuming these to be 'bad', I deleted them.

    So, from the above I have a workaround for my environment running Vanilla and hope this is helpful to others.

    Vanilla is excellent, tried it a LONG time ago and loved it even tho' only used to test in a dev setup, hoping this time to get to deploy for a client -- thanks to all concerned, from Mark O'Sullivan to plugin authors to other forum people for these great resources. Cheers, -Alan
  • anyone found a solution to this already? i'm finding the same problem in the same MAMP setup... don't dare to put this online yet...
  • right now i also am using the solution of changing the HTTP_METHOD to "http" and not "http://" and it's working fine for now. Am not sure if this is the proper way to solve it, though.
Sign In or Register to comment.