Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Redirect url including "localhost"

edited July 2009 in Vanilla 1.0 Help
Hello folks, First, thank all involved for this very cool, very interesting software! I've done a new install on a remote server, and I'll preface this by saying that I've done all sorts of installs of SMF, phpBB, and Joomla on the same servers with no installation issues. When I attempt to sign in, the redirect url comes as "http://localhost://www.mydomain.com/" rather than simply "http://www.mydomain.com". If I manually correct the address, I'm in and everything works from there. The web path to vanilla is set correctly to "http://www.mydomain.com". Cookie domain is "www.mydomain.com", and cookie path is set to "/". I've found numerous topics that are tangent to this issue, but nothing that has answered my question specifically. Any help would be greatly appreciated, I think the forum is terrific. Thanks! Matt

Comments

  • Options
    Examine the configuration file at conf/settings.php on your remote server and changes the strings to their correct value.
  • Options
    Thanks sirlancelot. I have examined that file and found nothing that looked wrong to me. Below are the contents of conf/settings.php. I have only changed the domain name to "mydomain", removed my name and email. See anything there that could cause a malfunctioning redirect? <?php // Application Settings $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = '/home/iguild/public_html/vanilla/'; $Configuration['DATABASE_PATH'] = '/home/iguild/public_html/vanilla/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/home/iguild/public_html/vanilla/library/'; $Configuration['EXTENSIONS_PATH'] = '/home/iguild/public_html/vanilla/extensions/'; $Configuration['LANGUAGES_PATH'] = '/home/iguild/public_html/vanilla/languages/'; $Configuration['THEME_PATH'] = '/home/iguild/public_html/vanilla/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/vanilla/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/vanilla/'; $Configuration['BASE_URL'] = 'http://mydomain.com/vanilla/'; $Configuration['HTTP_METHOD'] = 'http://'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://mydomain.com/vanilla/'; $Configuration['SUPPORT_EMAIL'] = 'myemail'; $Configuration['SUPPORT_NAME'] = 'myname'; $Configuration['APPLICATION_TITLE'] = 'Vanilla Forum'; $Configuration['BANNER_TITLE'] = 'Vanilla Forum'; $Configuration['COOKIE_DOMAIN'] = 'mydomain.com'; $Configuration['COOKIE_PATH'] = '/vanilla/'; $Configuration['SETUP_COMPLETE'] = '1'; $Configuration['DATABASE_VERSION'] = '2'; $Configuration['LAST_UPDATE'] = '1241487129';
  • Options
    edited May 2009
    $Configuration['HTTP_METHOD'] should be 'http' instead of 'http://'$Configuration['HTTP_METHOD'] = 'http';
    Was this a value you set yourself? If not, perhaps we have an issue with the installer...
  • Options
    Ok, interesting. I didn't change any of those values, so that's exactly what the installer created. Unfortunately I went ahead with an SMF installation for this site and a theme that's simple and similar to Vanilla styling. I'll try an additional Vanilla install later today and see if this solves the problem. Thanks so much for your help, sirlancelot.
  • Options
    That's exactly what the problem is, and it's being set that way during installation. I'd change that in a hurry!
  • Options
    Had the same problem with a new installation of Vanilla 1.1.8 today. Downloaded the conf/ files to my local server, changed the configuration file at conf/settings.php $Configuration['HTTP_METHOD'] = 'http'; as was suggested, uploaded back to the remote server and it worked just fine. Agree that it looks like an installer issue.
  • Options
    edited May 2009
    I installed two fresh copies of Vanilla 1.1.8 yesterday -- one local test version, one live version -- and both installations exhibited the odd intermittent login problems described above.

    Both conf/settings.php files (autogenerated from the installer) contained

    $Configuration['HTTP_METHOD'] = 'http://';
    instead of

    $Configuration['HTTP_METHOD'] = 'http';
    and all of the login problems were a result of redirect errors that produced URLs like:

    http://://mysite.com/discussions/
    I'd agree that this looks like an installer bug.
  • Options
    Not sure any more corroboration is needed, but I have a (very new) install that's doing the same thing; 1.1.7 upgraded to 1.1.8. Changing HTTP_METHOD appears to have fixed the issue here too.
  • Options
    @mushin; what SMF theme did you use that was like Vanilla? I may need to use SMF for another more 'noisy' forum with more bells and whistles, but I couldn't get SMF to look anything like Vanilla myself.
  • Options
    edited May 2009
    Love Vanilla, love this forum, many thanks for the hours and hours you folks have saved me already. Hoping you can help with the latest hurdle: Have also had the the same installer problem with a new install of Vanilla 1.1.7. Changed the HTTP_METHOD as recommended, but I'm still fielding two complaints from users: (1) It often requires two attempts to login or to add a comment. Often when a user adds a comment, he/she gets an "Unknown error" message, but the second click will post the comment. The first login sometimes takes the user to a "file not found" message. Workaround seems to be to hit the "Back" button, wait for the sign-up page to reappear, and sign in for a second time. Always seems to work on the second try; never requires a third attempt. Doesn't seem to matter whether you've clicked the "Remember me" cookie-installer or not. (2) Vanilla seems to kick users off for reasons that have nothing to do with the built-in timeout. It could be after 10 minutes or 2 hours. It typically happens when adding a comment (posting) or hitting the browser's "Back" button. It has happened to me once when attempting to save settings. Fixing the HTTP_METHOD string seems to have slightly alleviated these problems, but they still persist. Seems to happen to all users, regardless of the browser. Any ideas would be much appreciated. With all good wishes, Nick
  • Options
    mattmatt ✭✭
    Had the same problem in a fresh install today.

    Thanks for this post
Sign In or Register to comment.