HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

[Who's Online/MySQL Trouble] "Table 'i' is marked as crashed and should be repaired" (solved)

edited June 2009 in Vanilla 1.0 Help
When I tried logging into my forum (Vanilla 1.1.8) today, I got the following message:
Warning: mysql_query() [function.mysql-query]: Unable to save result set in /is/htdocs/wp1072360_RCVVWBD4TX/www/Vanilla/library/Framework/Framework.Class.MySQL.php on line 140
A fatal, non-recoverable error has occurred
Technical information (for support personel):

Error Message
An error occurred while attempting to retrieve the requested information.
Affected Elements
WhosOnline.GetGuestCount();

The error occurred on or near: Table 'i' is marked as crashed and should be repaired

For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs
As this has something to do with the "Who's Online" Extension, I tried deleting it, which allowed me into my forum again, but still led to the following error messages:
Warning: include(/is/htdocs/wp1072360_RCVVWBD4TX/www/Vanilla/extensions/WhosOnline/default.php) [function.include]: failed to open stream: No such file or directory in /is/htdocs/wp1072360_RCVVWBD4TX/www/Vanilla/conf/extensions.php on line 8

Warning: include() [function.include]: Failed opening '/is/htdocs/wp1072360_RCVVWBD4TX/www/Vanilla/extensions/WhosOnline/default.php' for inclusion (include_path='.:/usr/share/pear/php5') in /is/htdocs/wp1072360_RCVVWBD4TX/www/Vanilla/conf/extensions.php on line 8
Of course, these are only cosmetic fixes, because the problem is somewhere in the database. Sadly I'm pretty clueless about MySQL and when I looked into it, I didn't really find anything out of the ordinary. (And the forum itself works, so the problem should only be a specific table or something.)

So, any idea what happened here and how a noob like me could fix it?

Aaron

Comments

  • Strangely enough, what you describe happened to my instalation yesterday but with another table (UserDiscussionWatch). Open phpMyAdmin -> click on your vanilla database -> select all tables (checkbox) using the "Check All" link -> in the bottom (beneath the checkboxes) choose from the dropdown "With Selected": "Repair Table". That should solve it.
  • And it works again. Thanks!
Sign In or Register to comment.