Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Email to addresses at the host domain failing

edited October 2005 in Vanilla 1.0 Help
Hi, I'm using the latest release of Vanilla (great app BTW) and am having some trouble with registration notifications for users whose email address are at the same domain as the host. e.g. the host is www.execequity.com, notifications don't get to users with execequity.com mail addresses. All other addresses are ok. Has anyone experienced this? Or this more likely to be a problem with the server? Channing

Comments

  • Options
    sounds very much to me like some sort of dns problem. I see no reason php would be failing for this reason - easiest way to check would just be to make yourself a php file as so: <?php $Address = "email@execquity.com"; $Subject = "test email"; $Content = "Just checking this works!"; mail($Address,$Subject,$Content); echo "Mail sent to ".$Address.", with subject ".$Subject." and content: ".$Content; ?> Name it whatever you want .php and upload it then browse to it. If it mails you, then its an error in vanilla. Otherwise its almost certainly your server.
  • Options
    Thanks very much, I'll try that. Channing
  • Options
    Hi again, it looks like its a problem with our server, your script works perfectly for non execequity.com addresses. Thanks for the help. Channing
  • Options
    ok. I'd suggest it was a dns problem if your server is also the authoritative zone, but on the assumption users can send mail to each other it's a little confusing. Good look figuring that one out..
  • Options
    Hi, our host's support guys said: --- My test script gives error message: Warning: mail(): SAFE MODE Restriction in effect. The fifth parameter is disabled in SAFE MODE. in /home/www/execequity/phpmailtest.php on line 10 Warning: mail(): SAFE MODE Restriction in effect. The fifth parameter is disabled in SAFE MODE. in /home/www/execequity/phpmailtest.php on line 20 call to mail() returned So, I'm guessing that it has something to do with safemode being enabled either on your domain (via the php.ini file) or on the server in the PHP_INI_SYSTEM. The safe mode can be switched off through a php.ini file. The php.ini file needs to be uploaded into the cgi-bin folder and contain the line safe_mode = Off I have created the php.ini file for you and your script should work now. --- I don't know if this has any relevance to anyone else but I thought it worth posting the solution just in case. Channing
  • Options
    Um...i remember considering safemode but i discounted it because it seemed wierd that it'd only stop mail to the host domain. That's some rather odd behaviour. Atleast its fixed though. *note to self next time this bug comes up.
  • Options
    I guess my host must be doing something weird :-)
This discussion has been closed.