Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

After first install going to Dashboard gives me 404 error page*

edited September 2011 in Vanilla 2.0 - 2.8
Hi folks,

I have installed the latest vanilla forum, and have got to the 'dashboard', when I set it up I click the 'visit site' link and it gives me a 404 error! I am reading that this should by default be the 'discussions' page, however this does not seem to exist? do I need to create the initial forum before use? as there does not seem to be any options to do that? On some of the video's on the site, on the video there is in the left hand side nav of the dashboard a 'forum settings' option, however my dashboard does not have this option?

Am I being a bit silly here and missing something obvious? as I just want to have a simple forum setup?

ANy help would be gratefully appreciated!!!


  • Try turning off the rewriting of the URLs
    Open conf/config.php
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    change to
    $Configuration['Garden']['RewriteUrls'] = FALSE;
  • Thanks Underdog,

    Still no cigar, interestingly the config.php does not have the setting (apart from the DB stuff it had)

    $Configuration['Garden']['Title'] = 'Vanilla 2'; $Configuration['Garden']['Cookie']['Salt'] = 'KARSW3RTDL'; $Configuration['Garden']['Cookie']['Domain'] = ''; $Configuration['Garden']['Registration']['ConfirmEmail'] = TRUE; $Configuration['Garden']['Email']['SupportName'] = 'Vanilla 2'; $Configuration['Garden']['Installed'] = TRUE;

    It was in the config-defaults which I changed but still no cigar? any other ideas?
  • Copy the line into config.php
    and config-defaults is only there for the default values before you install vanilla.
    So add the rewriteurls line to your config.php and let's see what happens.
  • thanks again,

    Tried that but again no luck

    config looks like

    // Garden $Configuration['Garden']['Title'] = 'Vanilla 2'; $Configuration['Garden']['Cookie']['Salt'] = 'KARSW3RTDL'; $Configuration['Garden']['Cookie']['Domain'] = ''; $Configuration['Garden']['Registration']['ConfirmEmail'] = TRUE; $Configuration['Garden']['Email']['SupportName'] = 'Vanilla 2'; $Configuration['Garden']['Installed'] = TRUE; $Configuration['Garden']['RewriteUrls'] = FALSE;

    Only other variables is I am testing this out on a mac (Snow Leopard) using the apache which comes under Zend community edition?
  • UnderDogUnderDog MVP
    edited September 2011
    I don't know if apache goes on Mac. Now I'm almost certain the trouble is in the rewrite rules. Delete or rename the .htaccess file in your vanilla folder.

    Just to be sure. The Dashboard doesn't work either? Or is the dashboard the only thing that's working?

    also tell the name of the folder you installed vanilla in. Tell the URL you are trying to access (in your address bar)
  • Hi Underdog,

    Want to give a big thanks for helping me, it is greatly appreciated. I actually have tried a fresh install to see if I had missed anything - there appears to be no .htacess file in the vanilla app folder. Dashboard is working absolutely fine, so it is just the forum stuff which appears to not work..

    Is it worth me just trying on a linux box? assume ubuntu has many installs without such issues?
  • I'm missing answers to these 2 questions:
    also tell the name of the folder you installed vanilla in. Tell the URL you are trying to access (in your address bar)
    To go ahead after you've answered those questions... Normally users go to http://localhost/vanilla/discussions/ but in your case you could try to go to http://localhost/vanilla/index.php?p=/discussions or index.php?p=/discussions/ (i forgot which one of the 2 works)
    and then substitute "vanilla" for the folder you installed vanilla in. That's why I need answers to those 2 questions.
    Is it worth me just trying on a linux box?
    Of course! If you have a linux box, try to install vanilla on linux.
Sign In or Register to comment.