Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

My Forum is Down - Please Help!

edited January 2012 in Vanilla 2.0 - 2.8

I have noticed that my forum has been down for over 3 days now, http://motherwellyouthvoice.co.uk/vanilla/ it says Bonk something funky happened. Please bear with us whilst we iron out the kinks.
I would appreciate some support as I cannot even access the admin panel.

Answers

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    edited January 2012

    if u are using vanilla >= 2.0.18 Put

    $Configuration['Garden']['Debug'] = TRUE; 

    and if its < 2.0.18 put

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    in your config.php file

    this will give more details about the error only then it can be sorted out.
    you need to put these lines through ur FTP client

    UnderDog
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited January 2012

    On your webserver, add this line to the config.php file:

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    then try to access your forum. You should get the full details of the error, rather than the bonk page, and that will give you some idea of where the problem lies.

    Damn your fast, @sahotataran...

  • Whats my webserver? is that who the company i use to run my site through? sorry I dont know the technical stuff

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭

    well its going to be hard for me to explain and even more hard for u to understand if u dont know the technical stuff. m not trying to be rude or anything but - i dont know where to start from because even if u knew a little about it like ftp and webserver and anything we could have tried to solve your problem as soon as possible - all we need is for u to put the code i had given above into the config and rest would have been our job - m sorry i find myself helpless to help u right now

    UnderDog
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    bonk - you need to be able to access the files on your host's site - the company you run your site through.

    You ( or someone) must have done that to get vanilla started.

    If you can't get that far, you need to get hold of someone who can.

  • Right I am with Knet hosting and I downloaded the Vanilla forums from softalicious on the cpanel so it'll be in those settings then? and sorry bout this guys and thanks for support

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    bonk

    that's right.

    In Cpanel, go through FIle Manger and locate your vanilla/conf folder, and edit the config.php file as suggested.

  • ok thanks i'll try that :)

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭

    cool now u r on right track buddy. let us know as soon as u have made the change to your config.php. :)

    UnderDog
  • edited January 2012

    Right guys sorry about this but i managed to get it up but what part do i change??

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    I suspect it can go anywhere in there, but for neatness, add this line:

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    In the Garden$Configuration section.

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭

    @bonk just add the line $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    anywhere in there. and never again share your config.php here - you are sharing ur database username and password. remove it - the database details as soon as possible.

  • sorry guys didnt relise that all shared i'll remove it just now ... ooops and thanks

  • right thats me put it in and saved it :) what next please :)

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭

    your page http://motherwellyouthvoice.co.uk/vanilla/ should have been displaying the error out there but it still shows me the same BONK. - can you try clearing your cache in
    /cache/ folder?

  • Ok. I'm going to close this thread.

    Read what's said above.

    I will post it here, just to make you read it once more:

    if u are using vanilla >= 2.0.18 Put

    $Configuration['Garden']['Debug'] = TRUE; 

    and if its < 2.0.18 put

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    in your config.php file

    this will give more details about the error only then it can be sorted out.
    you need to put these lines through ur FTP client

This discussion has been closed.