Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

No thumbnails created

This discussion is related to the fileupload addon.

I am using xampp on my windows 7 pc. After attaching a file I recieve an error message in firebug:"NetworkError: 404 Not Found - http://localhost/uploads/thumbnails/FileUpload/4a/4d3906ccfac1424f88b10f5e0490e9.jpg". My C:\xampp\htdocs\uploads\thumbnails\FileUpload is also empty but I have original image in C:\xampp\htdocs\uploads\FileUpload Any ideas?

Answers

  • check permissions. on thumbnails/FileUpload

    grep is your friend.

    kirkpa31
  • Nope pretty sure thats not it

  • @michael1224 : Have you searched inside the sourcecode of Vanilla for the exact text "NetworkError"? There might be some pieces of text that point you in the right direction.

    I know Windows doesn't have "grep", but there are some editors that can search through the contents of all PHP files of Vanilla.

    When you find the pieces of code that help you out and you cannot figure out what goes wrong in those pieces of code, just post them here, 5 lines above and 5 lines under that exact piece of text will do the trick most of the time.

    I think it might be a renaming problem. Windows and especially Windows 7 can be pretty tricky in that area.

  • 422422 Developer MVP

    Shouldnt it be fileupload/thumbnails

  • michael1224 said:
    Nope pretty sure thats not it

    why so sure? The thumbnail hasn't been written.

    grep is your friend.

  • Seems a function Gdn_Upload::Parse is broken on Windows.

    Try to comment the line $Name = str_replace('\\', '/', $Name); in library/core/class.upload.php

    stavthewonderchickenMysteriousonlyonelove
  • well, that works better @jetman - thanks - it was driving me nuts trying to find where/how that -> C:\pub\htdocs\apps\vanilla/applications/dashboard/ ... was being generated . . . of course windows will see that as the /a option and quit following . . . cheers.

  • it didn't work for me

  • @jetman said:
    Seems a function Gdn_Upload::Parse is broken on Windows.

    Try to comment the line $Name = str_replace('\\', '/', $Name); in library/core/class.upload.php

    This solved the problem for me

  • Thanks you @jetman

Sign In or Register to comment.