Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Flaky Installation of

I downloaded, unzipped it, and ran the installer. The following happened: it created conf/config.php with all the info I put in the installer and created 32 database tables (GDN_*).

However, when click the submit button on the installer it just redirects me back to the same page.

The generated config file:

Poking around here, I decided maybe I should add Garden.Installed to the config, which I tried, and that resulted in a "Page not found" error when I load index.php

I turned on the debug mode but wasn't able to get it to spit out anything helpful, and I didn't see any log files being generated either by PHP or Vanilla, so I left it at that.

My setup:
Application Version:
PHP Version: 5.3.8-ZS5.5.0
Operating System: Linux
Server Software: Apache/2.2.16


  • Oh boy... I hope you're still installing on your localhost, even though you're saying you're installing on a Linux Server, which is perfectly allright...

    Can you turn on the debug modus and start over?

    $Configuration['Garden']['Debug'] = TRUE;
    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    The only thing I could find about returning back to the installer page was wrong write permissions on cache directories.

    I hope to get more info, once you install with the debugger on.

  • I started over, and did the following:
    rm -rf vanilla
    cd vanilla
    chmod -R 777 cache/ uploads/ config/

    I modified vanilla/conf/config-defaults.php to enabled debug mode and the masterview settings you mentioned (since I had no regular config file as this point)

    I then ran the installer again, and again it generated a config file but simply reloaded the page installer with no error.

    I verified that the webserver's user still has read/write permission to the cache and config folders afterward. (Permission:

  • aeryaery Gtricks Forum in 2.2 :) ✭✭✭

    Same happened with me once. Found out its because of windows was treating some files as read only.

    What I did? downloaded a new copy, extracted it and it worked like charm.

  • peregrineperegrine MVP
    edited April 2012

    if it were me, I would do what Aery suggested witht the following additions.

    since I assume this is new installation and you can start from scratch

    1) delete the vanilla directory
    2) delete the vanilla database with phpmyadmin or mysql
    3) read the installation requirements and ensure you meet them.
    4) check phpinfo()
         verify mod_rewrite  and install the mod if necessary
    5) download a new zip and wait for it to download (instead of clicking to force it) so you can see the version name.
    6) reinstall.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I re-downloaded and extracted it to /var/www/, verified I meet all the requirements for software versions and enabled modules/extensions, applied the 777 permission to the cache, conf, and uploads folders, and dropped/created the "vanilla" MySQL database.

    Just for fun, I tweaked the defaults config to enable rewrite debug (in hopes it would be more verbose). Other than that, I didn't modify anything else.

    Running the installer gave me the same results. Again, it created database tables but just re-loaded the install stuff. If I go to I get a page not found error.

    I'm not sure what a "successful" install looks like, but this is a comparison of my vanilla folder post-install to the default (just after unzipping) folder:

    I'm at a loss for what could be the problem and why the software isn't getting mad at me (with an error message, log file, exception, etc.) in a helpful way.

  • peregrineperegrine MVP
    edited April 2012

    edit: I just noticed you wrote
    you displayed in one of your images
    couldn't you http://localhost/vanilla/

    it looks like you have a rewrite url problem from my guess.

    or are you only giving some of the details.

    maybe this will help you:

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • is the database server (which is correct). is (not literally) where I have the virtualhost setup in Apache (also working correctly).

  • peregrineperegrine MVP
    edited April 2012

    do the apache logs give you help on where it thinks it is trying to go.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Nothing in the apache logs. I should note that when I say "page not found" error I mean from Vanilla. It's the pretty version Vanilla renders, not an apache 404.

  • Hm. I checked out the latest copy of master from Github (2e3f71c) and while the setup page did redirect me back to itself, the installation did seem to work. Going back to the homepage loaded a blank forum where I could start discussions and whatnot.

    I also tried a tarball from the 2.0.17x line, but got a bunch of errors about not being able to include models, so I bailed on that.

    So it appears my problem at least as something to do with the release I downloaded from the website.

  • mikesmoniker said:

    I don't understand the name of that zip file, but maybe it's just me. I think it's time to dive into the sourcecode.

    There's 1 last thing you can try. As soon as you have a config file, compare the config-defaults.php with that config.php file. Merge config-defaults.php into config.php and see what the differences are.

    Next step is to edit the sourcecode and trace the code that Vanilla is following on your server (if you understand what I mean). You have the debug modus on, so you can do something like:

    if($debug-modus == 'on') {echo "hello world";}

    I wish I could help you reproduce the problem, but I'm on a Windows box. I do have virtual hosts set up, but not my virtualhost is a simple name like 'myvanillahost'

  • That is the name of the download if you use the direct link (which I did so I could wget it).

    Since using the latest version from Github worked, and for now I'm just setting it up to try it out and compare it to a few other forum systems, that should suffice.

  • @UnderDog

    The random characters on a download appear on just about everything - plugins and core - depending on how you download. E.g. Besides the example above, if you click on download plugin or vanilla

    you get the message

    Your download should begin shortly

    If your download does not begin right away, click here to download now.

    if you click on the If your download does not begin right away, click here to download now.

    it will be random letters, if you wait for the download you will get the standard name.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @peregrine ok, gotit. @mikesmoniker ok, good that it works with the latest version from gitHub

  • i have the same problem as you. Can't install, but the latest code from github works. Thanks !

Sign In or Register to comment.