Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Fatal error: Class 'Gdn_Plugin' not found

edited July 2010 in Vanilla 2.0 - 2.3
Hi, I'm using 2.0 rc3 and I get the following error when I try to install Vanilla on my hosting provider (nearlyfreespeech.net):

Fatal error: Class 'Gdn_Plugin' not found in /f5/gasketguy/public/forum/plugins/GettingStarted/default.php on line 13

Installation went smoothly on my local server. Any clues as to why this would be happening???

Comments

  • TimTim Operations Vanilla Staff
    That's quite weird. Normally we explicitly include files like that in the bootstrap.php but I don't see it there. It probably should be, and I've just added it.

    If you want to do this for your install, find bootstrap.php and add
    require_once(PATH_LIBRARY_CORE . DS . 'class.plugin.php');
    A good place to put it would be right above require_once(PATH_LIBRARY_CORE . DS . 'class.pluggable.php');

    Sorry about that.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Ok, I added that line and now I get the following error:

    Fatal error: Class 'Gdn_SliceProvider' not found in /f5/gasketguy/public/forum/library/core/class.plugin.php on line 21
  • I avoided the issue by going down to RC2. Everything seems to be working fine now.
  • TimTim Operations Vanilla Staff
    You can also try going up to the latest RC code from http://www.vanillaforums.org/download/nightly ... sorry for the inconvenience :/

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • I get the following error when i want to post a discussion. Any options to solve this issue?

    Fatal error: Class 'MediaModel' not found in /srv/www/source/unstable/misc/plugins/FileUpload/class.fileupload.plugin.php on line 184
  • TimTim Operations Vanilla Staff
    This has been fixed. Please do not double post in the future. Additionally, you are a hosted customer, please email [email protected] with any issues!

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • edited July 2010
    Tim, do you happen to know what file or what github commit fixes this? I ran into this issue on our host server (not local devel) and wanted to have it fixed without reinstalling vanilla. Thanks!
  • I just updated my install of Vanilla via Wordpress and I am getting the same error as the first poster. I'm am hosting the forums on another host. But would love to use this forum software. Any clue what the issue/fix is?

  • Here's the strange way it happened for me:

    I uploaded the vanilla folder to my web server
    I set up url forwarding from forums.my-domain.com to my-domain.com/forums
    I waited until my server forwarding started working
    I decided to change the name of the folder, and re-set my server forwarding
    after changing the folder name and another successful forwarding set-up, I got the error mentioned above

    seems really strange and to have occurred from nowhere as I didn't start the vanilla set-up process yet, I was having all kinds of issue with url forwarding so I waited until that seemed to work perfectly

    Since I haven't really set up anything yet, I deleted the whole folder and re-uploaded it with the name I wanted and now everything is fine again.

  • Hello dear,
    I have downloaded latest 2 version of vanilla, it is working well at my localhost but when i uploaded localhost's vanilla form with database it shown me an error like

    "Fatal error: Class 'Gdn' not found in /home/testweb/public_html/discussion/bootstrap.php on line 47"

    I have deleted temporary cache files but it is not working.
    I am also a web developer from last 4 years, please let me know how can i overcome this problem.

    my gmail id: [email protected]
    Thanks in advance :)

    With Regards
    Kamlesh

    x00
Sign In or Register to comment.