HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Error "The import file is not in the correct format" in Vanilla Porter

This discussion is related to the Vanilla Porter addon.
CsabbencsCsabbencs
edited June 2011 in Vanilla 2.0 - 2.8
I used Vanilla Porter 1.5.2 to export my old Vanilla 1 forum. The export was successful: I got a single file, I named it 'export.txt'.
I installed Vanilla 2 successfully to my host, then I went to dashboard->import, I selected 'export.txt' to import and clicked 'Upload' .
The import didn't start, I got the following error message: 'The import file is not in the correct format.'
Please advise.

Best Answer

  • ToddTodd Chief Product Officer Vanilla Staff
    Accepted Answer
    I recommend putting the porter in a folder that is writable on your web server and then choosing the checkbox at the bottom that specifies to save to the server.

    Sometimes if you view the file in a browser and then save it things will get mangled a bit.

Answers

  • ToddTodd Chief Product Officer Vanilla Staff
    Accepted Answer
    I recommend putting the porter in a folder that is writable on your web server and then choosing the checkbox at the bottom that specifies to save to the server.

    Sometimes if you view the file in a browser and then save it things will get mangled a bit.
  • Thanks for the idea, but the option 'save the export file to server' is not available in my screen!
    I saw in the documentation that is should be there, but it is just NOT there.
  • ToddTodd Chief Product Officer Vanilla Staff
    edited June 2011
    To quote myself:
    I recommend putting the porter in a folder that is writable on your web server.
    peregrineUnderDog
  • Sorry, my fault. It worked when saving to the web server to a writable folder.
    Thanks again!
    UnderDog
  • I have the same problem and putting the export .txt file in the /upload/import (777) folder is not efficient at all. Any idea? http://vanillaforums.org/discussion/20899/importing-vanilla-1-to-2-problem

  • Ah ah ah! That was so crazy : You need to put the vanilla2export.php in a special folder in your old vanilla forum and set THIS FOLDER at 777, and THEN you'll see the apparition of a checkbox (onlythen :) ) to save the export on your web server and this file will be export_yourbase_txt.gz that you could then use, well formatted to import. Easy. Ah ah ah.

    UnderDog
  • UnderDogUnderDog MVP
    edited July 2012

    @allergie Can you please add that last knowledge to the Vanilla Wiki, it will be very useful to other users!

  • Just wanted to say thanks for this thread. Solved my issue thanks to it!

Sign In or Register to comment.