HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Solved] How to fix Broken URLs, broken bbcode etc. after Conversion

FanboyNYCFanboyNYC New
edited July 2012 in Vanilla 2.0 - 2.8

In the past few days, I have been pushing to make a move from PHPbb to Vanilla. A move for me was a big decision, seeing as my forum has been running since 2004. (If I had to start a forum from scratch, vanilla would be my choice hands down.)

I used the porter plugin, and I was able to work on the design to where I need it.

Now my only issue is, the majority of my links are broken. Once clicked, it seems to refresh to the same page. When I look at the code, it is [url= etc.
I have issues with codes and broken smileys (which I don't mind).

I have the NBBC installed, as well as Quotes; however, the issue remains.

I really want the urls fixed.

If anyone can suggest anything, please reply, thank you.

Comments

  • umm. same question as I asked you the last time you mentioned this. unless underdog is splitting discussions.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Nope, UnderDog is paying attention, just seen this one, but I think this one is a good topic start for a bunch of similar problems...

  • ToddTodd Chief Product Officer Vanilla Staff

    @FanboyNYC, phpBB has a messy way of doing bbcode and we do a conversion on the export side. However if this didn't work for whatever reason you will need to either a) fix the posts in Vanilla or b) fix the export and redo the import. I can help you with these, but I'd like to know what the problem is exactly first.

    I think what's best if you can grab one of the offending posts and paste it here. I want the raw text so click edit beside a comment and paste the contents of the textbox here.

    UnderDog
  • this is an issue with phpBB, it has a of unnecessary artefacts.

    You can use my version of the porter which has a bunch of phpBB fixes

    https://dl.dropbox.com/u/15933183/porterplus/porterplus.php

    grep is your friend.

    unixhero
  • FanboyNYCFanboyNYC New
    edited July 2012

    Thank you for all the responses.
    I used x00's version of the porter, and it worked way better than the porter I found under the Vanilla addons.
    The broken links are all fixed, as with quotes and smileys etc.

    I believe I am at the point to delete my phpbb3 forum from the /forum directory, and move the vanilla database into it.

    I am not sure of just renaming the current test vanilla directory to /forum would work, but I will give it a try, otherwise, I will do the entire process from scratch.

    Does anyone know which addon this forum uses for its B, I strikeout, url, quote options with posting?

  • SheilaSheila ✭✭

    FanboyNYC said:
    Does anyone know which addon this forum uses for its B, I strikeout, url, quote options with posting?

    Hi! This forum uses buttonbar.

    UnderDogFanboyNYC
  • UnderDogUnderDog MVP
    edited July 2012

    FanboyNYC said:
    I believe I am at the point to delete my phpbb3 forum from the /forum directory, and move the vanilla database into it.

    You don't have to move your 'database', but I think I know what you're trying to do, and I'll explain a little further below.

    otherwise, I will do the entire process from scratch.

    You certainly don't have to do that...

    I am not sure of just renaming the current test vanilla directory to /forum would work, but I will give it a try,

    After you rename your current 'vanilla' directory to 'forum', delete all the .ini files that are in the /cache directory.

    Let's see if that's (part of) the solution.

  • FanboyNYCFanboyNYC New
    edited July 2012

    Thank you everyone for the help. My forum has been officially moved. I wanted a more minimalism approach to having a forum on my site, after years of phpbb (which was really good to me). But the internet has changed a lot since 2004. Social networks have took precedence. I wanted social network logins, and the ability to integration with wordpress (unfortunately the integration with WP did not work as well, and I will be using disqus on wordpress and keeping the forum separate) Previously, I used WP-United for integration, but the script was abandoned.

    If anyone wants to see the forum, you can private message me.

    So far, there is tons of tweaks that I need to make, with the theme etc. The only downfalls that I have encountered so far is... When I place a Google Analytic code/script or Quantcast code into the default.master.tpl file for the Embed-Friendly theme, the forum dies... the "Bonk," message shows up. This also happened when I try to insert the Css Dropdown Menu that I use on the rest of the site.

    One other issue I've noticed so far, is in Chrome (did not see the issue when using Explorer or Firefox), when I hit the back button... back to a post/Thread, the entire forum loads again inside of the Categories/Start a new Discussion box.

    Gravatar plugin does not seem to be working either.

  • Sheila said:

    FanboyNYC said:
    Does anyone know which addon this forum uses for its B, I strikeout, url, quote options with posting?

    Hi! This forum uses buttonbar.

    Thank you so much, I have the buttonbar-plugin now on my forum.

    How was I able to give you "insightful" and "awesome" tags? hahaha. I am assuming the badges are the same plugin?

  • With Bonk errors there's only 1 link to follow and then post the results:

    What to do if I get a Bonk Error?

  • ToddTodd Chief Product Officer Vanilla Staff
    edited July 2012

    The only downfalls that I have encountered so far is... When I place a Google Analytic code/script or Quantcast code into the default.master.tpl file for the Embed-Friendly theme, the forum dies

    The curly braces in your google analytics code are messing with Smarty what you need to do is put javascript between {literal} tags:

    {literal}
     // Google Analytics Here
    {/literal}
    
    UnderDogFanboyNYC
  • FanboyNYCFanboyNYC New
    edited July 2012

    Todd said:

    The only downfalls that I have encountered so far is... When I place a Google Analytic code/script or Quantcast code into the default.master.tpl file for the Embed-Friendly theme, the forum dies

    The curly braces in your google analytics code are messing with Smarty what you need to do is put javascript between {literal} tags:

    {literal}
     // Google Analytics Here
    {/literal}
    

    That totally worked!!... for the quantcast code as well. Thank you
    I am not familiar at all with the {literal} code/Smarty, I will have to read up on that.

  • Thanks a lot for posting the porterplus . It took care of my phpbb3 conversion issues, in particular BBCODE and Smileys.

    Fantastic work!=)

Sign In or Register to comment.