Please upgrade here. These earlier versions are no longer being updated and have security issues.

Google signin not working (uses return url of HTTPS instead of HTTP)

edited June 2011 in Vanilla 2.0 - 2.8
I've got Google/OpenId enabled on my site. When I click the button to use google signin, it opens up a new window to google that says "The Page you requested is invalid."

After looking at the URL, there's a portion in there that says "return_to=http://www.moonlitzwave.com/forums/index.php?p=%2Fentry%2Fconnect%2Fopenid&display=popup&Target=%2F&openid.realm=https://www.moonlitzwave.com..."

Notice that the openid.realm is https but it should be http. Indeed, if I copy that URL and change it to http, it works great.

Is there a fix for this or is my only option to use HTTPS?
Tagged:

Comments

Sign In or Register to comment.