HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

"New Discussion" anomally ADVICE

i have the 2 vanilla installation using the same db.

  • one is on a "xampp" server (localhost) and with this when i click on the "new discussion" button everything work perfectly!
  • the second its on my server www.forumName.de on this one (the same copy from vanilla the same db) when i click the "new Discussion" i just recevie an error "The connection was reset".

If i test to make a disscusion on the localhost i can create the the new discussion and then when i conect to the online version i can see the discussion and i can add answer to it, but i can not create a new discussion.

Thank you in advance !

Comments

  • x00x00 MVP
    edited July 2013

    grep is your friend.

  • ok ok :) i'm sorry also in chrome it give's me "No data received" so everywere i try i have error on "New Discussion" !

    • I don't understand because the same vanilla that i have on my localhost it's also on the online version
    • Localhost works but online don't

    • How dose vanilla post the discussion in the db ?

    • It use's a special port ?
    • Can my database security prevent online vanilla to post in db ?

    What it's your oppinion on this were should i look ?

    Thank you.

  • x00x00 MVP
    edited July 2013

    Are you running apc/memcache?

    please also remember to provide you spec, and version as part of question etiquette.

    grep is your friend.

    bogdancristian
  • ok i have Vanilla Version 2.0.18.8 i am not using the embended version of the vanilla but i have created my own theam that i embended into my project so a normal user have access to the forum and only have acces to Disscusion/Inbox/Messages/User the rest of the forum works fine so when i want to make a new conversation works, comment's work just the new discussion ... from the big db i copyed the users with the passwords to the vanilla forum so they can login with the same user and pass(that works) yes the server on wich is the forum is apc but i don't know if its with /memcache. I am gonna look could this be the problem? Thank you for helping !

  • i just look and /memcache is not activ on the server

  • what is your stack apche/fcgi, apache/mod_php, nginx/php-fpm, etc?

    also rule out theme issues, by trying the default theme.

    grep is your friend.

    bogdancristian
  • with the default theme also the same error ... i will look for the command and i will post them here ! Thank you for thinking for my problem !

  • UnderDogUnderDog Moderator

    It feels like your server is IIS, otherwise check your server logs

  • Ok this are on my apache! So please tell me i have to add something or i have to take something out ? thank you !

    • LoadModule actions_module modules/mod_actions.so
    • LoadModule alias_module modules/mod_alias.so
    • LoadModule asis_module modules/mod_asis.so
    • LoadModule auth_basic_module modules/mod_auth_basic.so
    • LoadModule auth_digest_module modules/mod_auth_digest.so
    • LoadModule authn_alias_module modules/mod_authn_alias.so
    • LoadModule authn_anon_module modules/mod_authn_anon.so
    • LoadModule authn_dbd_module modules/mod_authn_dbd.so
    • LoadModule authn_dbm_module modules/mod_authn_dbm.so
    • LoadModule authn_default_module modules/mod_authn_default.so
    • LoadModule authn_file_module modules/mod_authn_file.so
    • LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
    • LoadModule authz_dbm_module modules/mod_authz_dbm.so
    • LoadModule authz_default_module modules/mod_authz_default.so
    • LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
    • LoadModule authz_host_module modules/mod_authz_host.so
    • LoadModule authz_owner_module modules/mod_authz_owner.so
    • LoadModule authz_user_module modules/mod_authz_user.so
    • LoadModule autoindex_module modules/mod_autoindex.so
    • LoadModule cache_module modules/mod_cache.so
    • LoadModule cern_meta_module modules/mod_cern_meta.so
    • LoadModule cgi_module modules/mod_cgi.so
    • LoadModule charset_lite_module modules/mod_charset_lite.so
    • LoadModule dav_module modules/mod_dav.so
    • LoadModule dav_fs_module modules/mod_dav_fs.so
    • LoadModule dav_lock_module modules/mod_dav_lock.so
    • LoadModule dbd_module modules/mod_dbd.so
    • LoadModule deflate_module modules/mod_deflate.so
    • LoadModule dir_module modules/mod_dir.so
    • LoadModule disk_cache_module modules/mod_disk_cache.so
    • LoadModule dumpio_module modules/mod_dumpio.so
    • LoadModule env_module modules/mod_env.so
    • LoadModule expires_module modules/mod_expires.so
    • LoadModule ext_filter_module modules/mod_ext_filter.so
    • LoadModule file_cache_module modules/mod_file_cache.so
    • LoadModule filter_module modules/mod_filter.so
    • LoadModule headers_module modules/mod_headers.so
    • LoadModule ident_module modules/mod_ident.so
    • LoadModule imagemap_module modules/mod_imagemap.so
    • LoadModule include_module modules/mod_include.so
    • LoadModule info_module modules/mod_info.so
    • LoadModule isapi_module modules/mod_isapi.so
    • LoadModule ldap_module modules/mod_ldap.so
    • LoadModule logio_module modules/mod_logio.so
    • LoadModule log_config_module modules/mod_log_config.so
    • LoadModule log_forensic_module modules/mod_log_forensic.so
    • LoadModule mem_cache_module modules/mod_mem_cache.so
    • LoadModule mime_module modules/mod_mime.so
    • LoadModule mime_magic_module modules/mod_mime_magic.so
    • LoadModule negotiation_module modules/mod_negotiation.so
    • LoadModule proxy_module modules/mod_proxy.so
    • LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
    • LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
    • LoadModule proxy_connect_module modules/mod_proxy_connect.so
    • LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
    • LoadModule proxy_http_module modules/mod_proxy_http.so
    • LoadModule rewrite_module modules/mod_rewrite.so
    • LoadModule setenvif_module modules/mod_setenvif.so
    • LoadModule speling_module modules/mod_speling.so
    • LoadModule ssl_module modules/mod_ssl.so
    • LoadModule status_module modules/mod_status.so
    • LoadModule substitute_module modules/mod_substitute.so
    • LoadModule unique_id_module modules/mod_unique_id.so
    • LoadModule userdir_module modules/mod_userdir.so
    • LoadModule usertrack_module modules/mod_usertrack.so
    • LoadModule version_module modules/mod_version.so
    • LoadModule vhost_alias_module modules/mod_vhost_alias.so
    • LoadModule php5_module "c:/wamp/bin/php/php5.3.10/php5apache2_2.dll"

    • IfModule !mpm_netware_module

    • IfModule !mpm_winnt_module
  • ok so i did the action on "New Disscusion" button 3 time and then i copyed the this erors here are the errors:

    • [Wed Jul 03 10:19:08 2013] [notice] Apache/2.2.21 (Win64) PHP/5.3.10 configured -- resuming normal operations
    • [Wed Jul 03 10:19:08 2013] [notice] Server built: Sep 24 2011 19:57:51
    • [Wed Jul 03 10:19:08 2013] [notice] Parent: Created child process 12888
    • [Wed Jul 03 10:19:08 2013] [notice] Child 12888: Child process is running
    • [Wed Jul 03 10:19:08 2013] [notice] Child 12888: Acquired the start mutex.
    • [Wed Jul 03 10:19:08 2013] [notice] Child 12888: Starting 150 worker threads.
    • [Wed Jul 03 10:19:08 2013] [notice] Child 12888: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:08 2013] [notice] Child 12888: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:21 2013] [notice] Parent: child process exited with status 255 -- Restarting.
    • [Wed Jul 03 10:19:21 2013] [notice] Apache/2.2.21 (Win64) PHP/5.3.10 configured -- resuming normal operations
    • [Wed Jul 03 10:19:21 2013] [notice] Server built: Sep 24 2011 19:57:51
    • [Wed Jul 03 10:19:21 2013] [notice] Parent: Created child process 5428
    • [Wed Jul 03 10:19:21 2013] [notice] Child 5428: Child process is running
    • [Wed Jul 03 10:19:21 2013] [notice] Child 5428: Acquired the start mutex.
    • [Wed Jul 03 10:19:21 2013] [notice] Child 5428: Starting 150 worker threads.
    • [Wed Jul 03 10:19:21 2013] [notice] Child 5428: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:21 2013] [notice] Child 5428: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:26 2013] [notice] Parent: child process exited with status 255 -- Restarting.
    • [Wed Jul 03 10:19:26 2013] [notice] Apache/2.2.21 (Win64) PHP/5.3.10 configured -- resuming normal operations
    • [Wed Jul 03 10:19:26 2013] [notice] Server built: Sep 24 2011 19:57:51
    • [Wed Jul 03 10:19:26 2013] [notice] Parent: Created child process 4932
    • [Wed Jul 03 10:19:26 2013] [notice] Child 4932: Child process is running
    • [Wed Jul 03 10:19:26 2013] [notice] Child 4932: Acquired the start mutex.
    • [Wed Jul 03 10:19:26 2013] [notice] Child 4932: Starting 150 worker threads.
    • [Wed Jul 03 10:19:26 2013] [notice] Child 4932: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:26 2013] [notice] Child 4932: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:41 2013] [notice] Parent: child process exited with status 255 -- Restarting.
    • [Wed Jul 03 10:19:41 2013] [notice] Apache/2.2.21 (Win64) PHP/5.3.10 configured -- resuming normal operations
    • [Wed Jul 03 10:19:41 2013] [notice] Server built: Sep 24 2011 19:57:51
    • [Wed Jul 03 10:19:41 2013] [notice] Parent: Created child process 11788
    • [Wed Jul 03 10:19:41 2013] [notice] Child 11788: Child process is running
    • [Wed Jul 03 10:19:41 2013] [notice] Child 11788: Acquired the start mutex.
    • [Wed Jul 03 10:19:41 2013] [notice] Child 11788: Starting 150 worker threads.
    • [Wed Jul 03 10:19:41 2013] [notice] Child 11788: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:41 2013] [notice] Child 11788: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:46 2013] [notice] Parent: child process exited with status 255 -- Restarting.
    • [Wed Jul 03 10:19:46 2013] [notice] Apache/2.2.21 (Win64) PHP/5.3.10 configured -- resuming normal operations
    • [Wed Jul 03 10:19:46 2013] [notice] Server built: Sep 24 2011 19:57:51
    • [Wed Jul 03 10:19:46 2013] [notice] Parent: Created child process 2092
    • [Wed Jul 03 10:19:46 2013] [notice] Child 2092: Child process is running
    • [Wed Jul 03 10:19:46 2013] [notice] Child 2092: Acquired the start mutex.
    • [Wed Jul 03 10:19:46 2013] [notice] Child 2092: Starting 150 worker threads.
    • [Wed Jul 03 10:19:46 2013] [notice] Child 2092: Starting thread to listen on port 80.
    • [Wed Jul 03 10:19:46 2013] [notice] Child 2092: Starting thread to listen on port 80.
  • UnderDogUnderDog Moderator

    @bogdancristian said:
    Parent: child process exited with status 255 -- Restarting.

    Let's see what google says about it. Can you search on site:stackoverflow.com

    bogdancristianhgtonight
  • ok i am looking into it now, be right back with info! thank's

  • So i think i have a solution:

    • Bug acknowledged and hopefully a fix soon forthcoming

    March 23, 2012 at 5:38am
    This bug reported previously as PHP bug 60758 has been acknowledged so hopefully a fix will be implemented in 5.3.11.

    • May 2, 2012 at 8:05pm

    Looks like this bug has been fixed in 5.3.11.

    • So on my appache server i have PHP 5.3.10 and on my localhost i have PHP 5.4.16 and i think this is the solution.(HOPE)
    • I am gonna update the PHP 5.3.10 on the this night (because i have other app on the server).
    • I am gonna post the result !

    Thank you guy's for the support !

    hgtonightUnderDogAdrian
  • did you get the solution ?
    if yes, please let me know.
    I got the same problem here.

  • @nawfreda said:
    did you get the solution ?
    if yes, please let me know.
    I got the same problem here.

    Well the answer to that is stated above, if indeed this is the same issue you need to upgrade to a stable version of php.

    grep is your friend.

  • Thank you
    It is working now after upgrade php version :smiley:

    vrijvlinder
Sign In or Register to comment.