Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Vanilla Forums lastest version installer not working

Hello,

I just downloaded Vanilla Forums on my localhost using MAMP.
The Setup Wizard does not continue when pressing continue in the installer. It writes the MYSQL Tables into my DB, but then doesn´t continue? What is the problem?

Thanks

Comments

  • Aaah, Vanilla Latest Version ... That helps... Let's assume 2.0.18.10 ... http://vanillaforums.org/addon/vanilla-core-2.0.18.10 Then when the installer doesn't work, you turn on the Error Reporting. Open index.php and find these lines :

    error_reporting(E_ERROR | E_PARSE | E_CORE_ERROR | E_COMPILE_ERROR | E_USER_ERROR | E_RECOVERABLE_ERROR);
    ini_set('display_errors', 0);
    ini_set('track_errors', 1);
    

    Let's turn on ini_set('display_errors', 0); to ini_set('display_errors', 1); and maybe play with the error_reporting settings when you don't get an error yet.

    peregrinehgtonight
  • @NS2jens

    • download the core version again,

    • check and adjust your folder permissions and ownership. esp. /conf /cache /compile config.php.

    • tell us the version number of vanilla you are using.

    • attach a screenshot of where it gets stuck and add more details.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDoghgtonight
  • NS2jensNS2jens New
    edited December 2013

    display_errors is set to 1 by default. It is not showing any errors. After entering my setup details, and proceeding with "continue ->" the page refreshes and deletes my input text. The MySQL DB gets filled with Vanillaforums tables. I am stuck at the first page of the installer. Using Version vanilla-core-2-0-18-10.zip. Looking at the config files, it applied my settings. Using PHP 5.5

  • Check your folder permissions and list the permissions for /conf and /conf/config.php
    attach your config.php as a zip file (after you change your password and sensitive information).

    see if these are in your config.php and add them if not

            // EnabledApplications
            $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
            $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDoghgtonight
  • phreakphreak VanillaAPP - White label iOS and Android App MVP

    @NS2jens: Hi i tested the latest Vanilla 2.1b2 with the latest MAMP and experienced the same problem. I also switched PHP Versions in MAMP. I also had the same problem with DEBUG = True not coming through (eh, that rhymes ;) ), because it's just leading to a blank page.

    I also experienced this problem with another CMS software, so this might be a problem with MAMPs recent release in general. don't know for sure

    hgtonightShadowdareR_J
  • peregrineperegrine MVP
    edited December 2013

    so this might be a problem with MAMPs recent release

    insightful

    I also had the same problem with DEBUG = True not coming through (eh, that rhymes :wink: ), because it's just leading to a blank page.

    $Configuration['Debug'] = TRUE;    //  try this for 2.1 and above
    
    $Configuration['Garden']['Debug'] = TRUE;  // try this for 2.0.18
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I also had the same problem with DEBUG = True not coming through (eh, that rhymes :wink: ), because it's just leading to a blank page.

    Noo, Noooh, Nooooh ... Not a blank page! Rely on those error_reporting settings and especially the ini_set settings. DEBUG is for something else. I think it's for throwing DEBUG messages while the page loads. It's not really something like adding / changing the template to that well known setting we all make when we get a Bonk error.

    Something is going wrong with the Ajax when the user wants to post the DataBase information and save the Config settings to conf/config.php and it returns to the default setup page. There's something in the setup code that happens to make it do that. (a 'return' somewhere in the Setup code)

    hgtonight
  • peregrineperegrine MVP
    edited December 2013

    save the Config settings to conf/config.php

    the last person who had this problem had incomplete writing to config.php

    Not a blank page! Rely on those error_reporting settings and especially the ini_set settings. DEBUG is for something else. I think it's for throwing DEBUG messages while the page loads.

    in vanilla2.1 the impact of

    $Configuration['Debug'] = TRUE; // try this for 2.1 and above

    if this is set in config.php

    $Configuration['Debug'] = TRUE;

    from bootstrap line which equates to

    Debug(C('Debug', FALSE));

    from functions.general.php

        if (!function_exists('Debug')) {
           function Debug($Value = NULL) {
              static $Debug = FALSE;
              if ($Value === NULL)
                 return $Debug;
    
              $Debug = $Value;
              if ($Debug) {
                 error_reporting(E_ALL & ~E_STRICT);
                 ini_set('display_errors', 1);
              } else
                 error_reporting(E_ERROR | E_PARSE | E_CORE_ERROR | E_COMPILE_ERROR | E_USER_ERROR | E_RECOVERABLE_ERROR);
           }
        }
    

    but modifying via index.php might be helpful during install process. as Underdog says

    in vanilla 2.1.10 automatically set.

    in index.php

    // Report and track all errors.
    error_reporting(E_ERROR | E_PARSE | E_CORE_ERROR | E_COMPILE_ERROR | E_USER_ERROR | E_RECOVERABLE_ERROR);
    ini_set('display_errors', 'on');
    ini_set('track_errors', 1);
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDoghgtonight
  • onreaonrea New
    edited December 2013

    Hi; I have the same problem. I wanted to create a new topic, but I saw this on the top of the list.

    My Machine: Ubuntu 13.10, updated

    My web server: LAMP, latest version

    My Vanilla: vanilla-core-2-0-18-10 and 2-0-18-9 and 2-0-18-4

    I unziped the vanilla package under /var/www and set the correct permissions: # chmod -R 777 /var/www/vanilla/conf; chmod -R 777 /var/www/vanilla/uploads; chmod -R 777 /var/www/vanilla/cache -> Then I create a new database using phpMyAdmin -> then I run vanilla script by http://127.0.0.1/vanilla -> I filled details and pressed "Continue" button -> BUT it returned to the installation page, while its database is written and config.php file has contained my input information! I tried installation for different version, but: failed

    I thought it's because of my web server, so I tried for installing WordPress and it installed successfully!

    What's wrong with Vanilla?

    UnderDog
  • UnderDogUnderDog Moderator
    edited December 2013

    You guys need to do some debugging in /applications/dashboard/controllers/setupcontroller.php
    Lines 75-84 and the 'Configure()' function (line 107 and beyond). Double and triple check whether the contents of PATH_APPLICATIONS . DS . 'dashboard' . DS . 'settings' . DS . 'structure.php'); was executed, I understand that the DB was created, but now the structure needed to be built in the DataBase, was that done?

    Go over all the 'SaveToConfig' lines, decho('something') right before it, exit, anything. That's debugging. It needs to be done to resolve this problem. For example : Garden.Installed wasn't written to the config file. Why? Does the program get there?

  • UPDATE: I tried for v2.1 (downloaded from this link) and it installed successfully, now is runnig! what's 2.0.18.x problem on installation process?

    Is 2.1 safe to work on it? (The forum is still in my mind and I'm going to customize vanilla skin for it)

  • peregrineperegrine MVP
    edited December 2013

    @onrea said:
    Hi; I have the same problem. I wanted to create a new topic, but I saw this on the top of the list.

    My Machine: Ubuntu 13.10, updated

    My web server: LAMP, latest version

    My Vanilla: vanilla-core-2-0-18-10 and 2-0-18-9 and 2-0-18-4

    I unziped the vanilla package under /var/www and set the correct permissions: # chmod -R 777 /var/www/vanilla/conf; chmod -R 777 /var/www/vanilla/uploads; chmod -R 777 /var/www/vanilla/cache -> Then I create a new database using phpMyAdmin -> then I run vanilla script by http://127.0.0.1/vanilla -> I filled details and pressed "Continue" button -> BUT it returned to the installation page, while its database is written and config.php file has contained my input information! I tried installation for different version, but: failed

    I thought it's because of my web server, so I tried for installing WordPress and it installed successfully!

    What's wrong with Vanilla?

    not sure - why its happening. But you can resolve by adding these two lines to your config.php.

     // EnabledApplications
    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
    $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    

    What happens when you run vanilla script with localhost instead of 127.0.0.1 ?

    are all folders and files in vanilla readable by the owner

    create a test file called testowner.php and run it. that will give you the owner and group.

    <?php system("id");?>

    make sure owner matches the owner matches all folders and files in vanilla
    try chmod -R 755 for all of vanilla and chown to all files and folders to what is reflected above in testowner

    and then rerun

    chmod -R 777 /var/www/vanilla/conf
    chmod -R 777 /var/www/vanilla/uploads 
    chmod -R 777 /var/www/vanilla/cache 
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @peregrine said: you can resolve by adding these two lines to your config.php.

    I done, but not solved!

    What happens when you run vanilla script with localhost instead of 127.0.0.1 ?

    no difference

    are all folders and files in vanilla readable by the owner

    I think yes, because I try for v2.1 in the same way and it installed successfully

    create a test file called testowner.php and run it. <?php system("id");?>

    uid=33(www-data) gid=33(www-data) groups=33(www-data)

    try chmod -r 755 for all of vanilla and chown to all files and folders to what is reflected above in testowner and then rerun chmod -R 777 /var/www...

    # chmod -R 755 *
    # chmod -R 777 conf; chmod -R 777 uploads; chmod -R 777 cache

    It wasn't useful. after these changes, here is testowner.php again:

    uid=33(www-data) gid=33(www-data) groups=33(www-data)

  • peregrineperegrine MVP
    edited December 2013

    I think yes,

    you need to check

    to change owner you can...
    chown to all files and folders

    chown -R www-data:www-data /vanilla

    to make www-data group and owner of all files and folders.

    perhaps vanilla 2.1 cookies and folders are interfering with vanilla 2.0.18.10 installation. doy you have everything separated correctly, and have you logged out of vanilla 2.1 when trying to install.

    It wasn't useful. after these changes, here is testowner.php again:

    uid=33(www-data) gid=33(www-data) groups=33(www-data)

    testowner will always report the same results for you. it just shows the owner of the process that runs when you click on your site's web pages. Some people mismatch owner and group of file foders with owner of the process that runs when you click on your site's web pages and run into problems.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @onrea said:
    UPDATE: I tried for v2.1 (downloaded from this link) and it installed successfully, now is runnig! what's 2.0.18.x problem on installation process?

    Is 2.1 safe to work on it? (The forum is still in my mind and I'm going to customize vanilla skin for it)

    2.1 is for testing purposes only. It will take a while before it goes final. I would make the updates that are announced in the security update if you would still use 2.1.

    It's still interesting what's wrong with 2.0.18.x on LAMP and WAMP. Maybe you can add those debugging messages. Depends on whether you want to stick with 2.0 or go for 2.1.

    2.1 means creating bug reports on github if you run into bugs.

    onrea
  • TlesTles New
    edited April 2014

    Im using MAMP 2.2
    I had the same problem with vanilla 2.0.18.10. The Setup Wizard did not continue as NS2jens said. DB was created with values but I could not go further from the first step.
    I solved it editing config.php as peregrine said. now my confing.php looks like

    // Database
    $Configuration['Database']['Name'] = '1234';
    $Configuration['Database']['Host'] = 'localhost';
    $Configuration['Database']['User'] = 'root';
    $Configuration['Database']['Password'] = 'root';
    
    // EnabledPlugins
    $Configuration['EnabledPlugins']['GettingStarted'] = 'GettingStarted';
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    
    // EnabledApplications
    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
    $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    
    // Garden
    $Configuration['Garden']['Title'] = '1234';
    $Configuration['Garden']['Cookie']['Salt'] = '3GRGRVJCNE';
    $Configuration['Garden']['Cookie']['Domain'] = '';
    $Configuration['Garden']['Registration']['ConfirmEmail'] = TRUE;
    $Configuration['Garden']['Email']['SupportName'] = '1234';
    $Configuration['Garden']['Version'] = '2.0.18.10';
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['CanProcessImages'] = TRUE;
    $Configuration['Garden']['Installed'] = TRUE;
    
  • Thanks for sharing some knowledge. This would really help...

Sign In or Register to comment.