Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Solved] [Split] Problem with HTML tables in Discussions*

UnderDogUnderDog Moderator
edited January 2014 in Vanilla 2.0 - 2.8
«1

Comments

  • Cybernomad, did you resolve this issue? I am having the same exact problem. Thanks!

  • @BeeZe455 said:
    Cybernomad, did you resolve this issue? I am having the same exact problem. Thanks!

    @BeeZe455, I would post a new thread following forum guidelines posting you vanilla version, etc. It is unlikely you are going to get a reply from someone who last posted in 2010.

    tables should work see.

    Cell 1.1 Cell 2.1
    Cell 1.2 Cell 2.2

    You are definitely using HTML or markdown formatter? Anyway I'd post a new discussion.

    grep is your friend.

  • Yeah ... I've split the discussion...

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Table code seem to work fine on here, but on my forum I have to remove 'new lines', so the code is continuous.

    I do it by pasting the table code in Word and then removing paragraph marks.

    Someone else posted this as a solution in another thread a while ago; apologies for not assigning the proper credit!.

    Column 1 Column 2 Column 3
    Data item 1 New 1 Blah 1
    Data item 2 New 2 Blah 2
    Data item 3 New 3 Blah 3
    UnderDoghgtonight
  • I switched to htmlpurifier and got it to work. Borders do not, but that is an HTMLPurifier issue.

    UnderDog
  • htmlpurifier is fine if you have a small forum, but it is a performance hit on a larger forum.

    grep is your friend.

  • BeeZe455BeeZe455 New
    edited January 2014

    TABLE TEST BELOW

    Snowmobile Trail Conditions/Update

    Trail Location Condition Comments/Last Groomed
    North to Canada Open Groomed in good condition.
    East to Rockwood/Pittston Farm Open Groomed in good condition.
    South to Lake, Parlin, The Forks Open Groomed in good condition.
    In Town Trail Open Groomed in good condition.
  • Tables do work here. Still without borders. Could somebody describe how it works on this forum? The purifier and such?

  • peregrineperegrine MVP
    edited January 2014

    @BeeZe455 said:
    Tables do work here. Still without borders. Could somebody describe how it works on this forum? The purifier and such?

    why not put some defaults in you css for a few different tables and assign classes.
    the people could use things like td class="Alt Borderthick colorBlack".
    or tr class="Alt Borderthick colorBlack".

    once you gave them a list. all the css willwork fine in tables if you put it in your custom.css.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • The border thing is one issue and is also an issue on this forum, but the whole other issue is my forum does not format the same code unless I use HTMLPurifier. HTMLLawed (htmLawed 1.1.9.3, 17 May 2010) that came with my vanilla does not format it. Does this forum use HTMLLawed?

  • peregrineperegrine MVP
    edited January 2014

    I can post tables in vanilla 2.0.18.10 just like this forum. and I can add classes to custom.css to make tables have borders,etc and any parameter I want.

    It is unclear what your version is, what you are after, and what your issue is.

    a few screenshots could help.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • vanilla-core-2-0-18-9 -- You using htmllawed or htmlpurifier?

  • upgraded to 2.0.18.10 and disabled purifier and enabled htmlawed. No formatting of table. You can see a live test at:

    http://neriders.com/discussion/107/vanilla-table-issue-test#Item_1

  • BeeZe455BeeZe455 New
    edited January 2014

    Table code looks like this here:

    Snowmobile Trail Conditions/Update

    <

    div align="center">

    <table  border="1" cellspacing="0" cellpadding="4">
    <tr><td   wrap align="left"  valign="middle">
    </td>
    <td   wrap align="left"  valign="middle">
    <font face="Arial" color="Black" size="3"><b>
    Trail Location
    </b></font></td>
    <td   wrap align="left"  valign="middle">
    <font face="Arial" color="Black" size="3"><b>
    Condition
    </b></font></td>
    <td   wrap align="left"  valign="middle">
    <font face="Arial" color="Black" size="3"><b>
    Comments/Last Groomed
    </b></font></td>
    </tr><tr><td   wrap align="left"  valign="middle">
    <img src="http://www.borderridersclub.com/ITS89.jpg" border="0" alt="" name="img1" title="" id=""  width="75" height="100"align=" "  ></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    North to Canada
    </font></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    Open
    </font></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    Groomed in good condition.
    </font></td>
    </tr><tr><td   wrap align="left"  valign="middle">
    <img src="http://www.borderridersclub.com/ITS88.jpg" border="0" alt="" name="img2" title="" id=""  width="75" height="100"align=" "  ></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    East to Rockwood/Pittston Farm
    </font></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    Open
    </font></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    Groomed in good condition.
    </font></td>
    </tr><tr><td   wrap align="left"  valign="middle">
    <img src="http://www.borderridersclub.com/ITS89.jpg" border="0" alt="" name="img3" title="" id=""  width="75" height="100"align=" "  ></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    South to Lake, Parlin, The Forks
    </font></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    Open
    </font></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    Groomed in good condition.
    </font></td>
    </tr><tr><td   wrap align="left"  valign="">
    <img src="http://www.borderridersclub.com/Club.jpg" border="0" alt="" name="img4" title="" id=""  width="75" height="100"align=" "  ></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    In Town Trail
    </font></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    Open
    </font></td>
    <td   wrap align="left"  valign="">
    <font face="Arial" color="Black" size="3">
    Groomed in good condition.
    </font></td>
    </tr></table>
    
  • BeeZe455BeeZe455 New
    edited January 2014

    <

    table>

    <

    div>

  • The posting here is definately different then my forum. Maybe because I am using cleditor?

  • Who thought a table with a border would be this hard. LOL

  • Table code works fine if I run the test in /plugins/HtmLawed/htmLawed/htmLawedTest.php, so I know it is not lawed or my server.

  • BeeZe455BeeZe455 New
    edited January 2014

    OK, spent some time on this and not sure exactly what it is, but the CRLF is causing it in Vanilla. Works fine on htmLawed test. Works fine with htmLawed disabled. Works fine with HTMLPurifier. htmLawed and vanilla it does not work. Changed plugin config and still did not work. Removing the CRLF seems to be the only work around, but I would not consider this a fix or solved.

  • there is a cofig option Garden.Format.ReplaceNewlines you could set it to FALSE.

    I affects all newlines, but if you are using WYIWYG it shouldn't be a problem.

    grep is your friend.

    UnderDog
Sign In or Register to comment.