Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

PHP Parse error after hosting company updated from PHP 5.2 to 5.3

The hosting company where our Vanilla Forums 2.0.18.8 forum runs recently updated PHP from 5.2.17 to 5.3.27. After the update, we started getting these errors:

PHP Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING in /library/core/class.pluginmanager.php(766) : eval()'d code on line 1

I haven't seen where anyone else has gotten these errors. For now, the site has been moved to a server that is still on PHP 5.2.17 but the hosting company wants to move it back to PHP 5.3.27 as soon as possible.

Comments

  • chanhchanh OngETC.com - CMS Researcher ✭✭

    It sounds like your hosting provider server might have short tag turn on which might cause that error.

    You can try add this line below in your .htaccess to see if that will stop the error.

    php_value short_open_tag off

    hgtonight
  • businessdadbusinessdad Stealth contributor MVP
    edited April 2014

    I agree with @chanh, it must be something in PHP configuration. I found this on another forum:

    The error can occur if magic_quotes_gpc is off, but magic_quotes_runtime is on. Entry in .htaccess fixed it:

    <IfModule mod_php5.c> 
    php_flag magic_quotes_gpc off 
    php_flag magic_quotes_runtime off 
    php_flag magic_quotes_sybase off 
    </IfModule>
    

    Disclaimer: I haven't tried the above, just reporting a suggestion I found.

    hgtonightLinc
Sign In or Register to comment.